summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven! Ragnarök2020-06-27 17:36:03 -0400
committerSteven! Ragnarök2020-06-27 17:36:03 -0400
commit65c4b46c9c98a0c084b4d13b76d9b7876faab007 (patch)
tree15096904ab2a7fee39fef45a2cbd9082aa7907f1
downloadaur-65c4b46c9c98a0c084b4d13b76d9b7876faab007.tar.gz
Initial openelp AUR package.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD33
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7aaaddb44264
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = openelp
+ pkgdesc = Open source EchoLink Proxy
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/cottsay/openelp
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = pcre2
+ backup = etc/ELProxy.conf
+ source = openelp-0.8.0.tar.gz::https://github.com/cottsay/openelp/archive/v0.8.0.tar.gz
+ md5sums = 6c53dd1fc35c330d3f970122fd91849c
+
+pkgname = openelp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3ee1d6ae04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46d0da793741
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Steven! Ragnarök <steven@nuclearsandwich.com>
+pkgname=openelp
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Open source EchoLink Proxy"
+arch=('x86_64')
+url="https://github.com/cottsay/openelp"
+license=('BSD')
+depends=(pcre2)
+makedepends=(cmake)
+backup=(etc/ELProxy.conf)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+md5sums=('6c53dd1fc35c330d3f970122fd91849c')
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver/build"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make install
+ install -Dt "$pkgdir/etc/" "$pkgdir/usr/etc/ELProxy.conf"
+ rm -r "$pkgdir/usr/etc"
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname/" "$srcdir/$pkgname-$pkgver/LICENSE"
+}