summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Gust2023-09-06 19:03:39 -0600
committerJeremy Gust2023-09-06 19:03:39 -0600
commit65c6606af45ae89a4f89d68d6fb49b8ba4f0a534 (patch)
tree7775840418a460e96ff5563e3a5a34e9257414aa
parent9c3dc7bb4e51f351f0c17535f2bf66c5adfc2392 (diff)
downloadaur-65c6606af45ae89a4f89d68d6fb49b8ba4f0a534.tar.gz
Updated to version 0.4.4, now built with meson
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--sysctl.patch11
4 files changed, 22 insertions, 62 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 4fb5bb4e54ac..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,14 +0,0 @@
-pkgbase = slurm
- pkgdesc = Monitoring traffic statistics in realtime
- pkgver = 0.4.2
- pkgrel = 1
- url = https://github.com/mattthias/slurm/wiki
- arch = i686
- arch = x86_64
- license = GPL
- makedepends = scons
- depends = ncurses
- source = https://github.com/mattthias/slurm/archive/upstream/0.4.2.tar.gz
-
-pkgname = slurm
-
diff --git a/.SRCINFO b/.SRCINFO
index faeacf47aaee..1075711973ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = slurm
- pkgdesc = Monitoring traffic statistics in realtime
- pkgver = 0.4.3
- pkgrel = 2
- url = https://github.com/mattthias/slurm/wiki
- arch = i686
+ pkgdesc = yet another network load monitor
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/mattthias/slurm
arch = x86_64
- license = GPL
- makedepends = cmake
+ license = GPL2
+ makedepends = meson
depends = ncurses
- source = https://github.com/mattthias/slurm/archive/upstream/0.4.3.tar.gz
- source = sysctl.patch
- md5sums = ff39b8e1fd31274ba1bb36d4aadc1d48
- md5sums = b8badc91fcfcfefebf68f1e4635c6e5f
+ source = slurm-0.4.4:https://github.com/mattthias/slurm/archive/upstream/0.4.4.tar.gz
+ sha256sums = 2f846c9aa16f86cc0d3832c5cd1122b9d322a189f9e6acf8e9646dee12f9ac02
pkgname = slurm
-
diff --git a/PKGBUILD b/PKGBUILD
index 71bc6f850a1c..cdb948fd2e31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,26 @@
-# Maintainer: Alexis Janon <kardyne -at- gmail -dot- com>
+# Maintainer: Jeremy Gust <jeremy AT plasticsoup DOT net>
+# Contributor: Alexis Janon <kardyne -at- gmail -dot- com>
# Contributor: Kyle Keen <keenerd@gmail.com>
# Contributor: Zhukov Pavel <gelios@gmail.com>
# Contributor: Christof Musik <christof@senfdax.de>
# Contributor: Falconindy
pkgname=slurm
-pkgver=0.4.3
-pkgrel=2
-pkgdesc="Monitoring traffic statistics in realtime"
-url="https://github.com/mattthias/slurm/wiki"
-license=("GPL")
-arch=('i686' 'x86_64')
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="yet another network load monitor"
+url="https://github.com/mattthias/slurm"
+license=("GPL2")
+arch=('x86_64')
depends=('ncurses')
-makedepends=('cmake')
-source=("https://github.com/mattthias/$pkgname/archive/upstream/$pkgver.tar.gz"
- "sysctl.patch")
-md5sums=('ff39b8e1fd31274ba1bb36d4aadc1d48'
- 'b8badc91fcfcfefebf68f1e4635c6e5f')
-
-prepare() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/sysctl.patch"
-}
+makedepends=('meson')
+source=("${pkgname}-${pkgver}:${url}/archive/upstream/${pkgver}.tar.gz")
+sha256sums=('2f846c9aa16f86cc0d3832c5cd1122b9d322a189f9e6acf8e9646dee12f9ac02')
build() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ arch-meson ${pkgname}-${pkgver} build
+ meson compile -C build
}
package() {
- cd "$srcdir/$pkgname-upstream-$pkgver/build"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../slurm.1 "$pkgdir/usr/share/man/man1/slurm.1"
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/sysctl.patch b/sysctl.patch
deleted file mode 100644
index 014ec1ad53c7..000000000000
--- a/sysctl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --unified --recursive --text package.orig/os.h package.new/os.h
---- package.orig/os.h 2015-08-16 19:54:19.000000000 +0200
-+++ package.new/os.h 2020-09-20 23:55:27.463447823 +0200
-@@ -177,7 +177,6 @@
- #elif defined (__linux__) /* L I N U X */
- #include <stdio.h>
- #include <sys/param.h>
--#include <sys/sysctl.h>
- #include <stdlib.h>
- #include <stdarg.h>
- #include <unistd.h>