summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-08-23 16:45:57 +0100
committerHans-Nikolai Viessmann2016-08-23 16:45:57 +0100
commit65ddba6e1eac241a6a5c1665aa7b1b2be0adb68d (patch)
tree1827d877d8eb6ff5774777f06aa43215ee1d4539
parent1ce91db9cb8d3440f06807b9866b217fefbbd05f (diff)
downloadaur-65ddba6e1eac241a6a5c1665aa7b1b2be0adb68d.tar.gz
Updated to 2.04
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG.md16
-rw-r--r--PKGBUILD6
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6897accc5b1..4141f76e6423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sshprint
pkgdesc = A Perl script to print local files on remote printers using SSH
- pkgver = 2.03
+ pkgver = 2.04
pkgrel = 1
url = https://github.com/hv15/sshprint
install = sshprint.install
@@ -9,10 +9,13 @@ pkgbase = sshprint
license = MIT
depends = perl>=5.22.0
depends = openssh
+ depends = perl-log-log4perl
+ depends = perl-config-simple
+ depends = perl-net-openssh
conflicts = sshprint<=1.6.3
options = !emptydirs
- source = https://github.com/hv15/sshprint/archive/2.03.tar.gz
- md5sums = 239989d27219722bc2229b13501cb555
+ source = https://github.com/hv15/sshprint/archive/2.04.tar.gz
+ md5sums = 8790659a28cb4e64fc16b860f3e6e38f
pkgname = sshprint
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ab7af6508cb2..c3662732310f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,6 +3,19 @@
## [Unreleased]
Nothing to report...
+## [2.04] - 2016.08.23
+### **Fixes**
+- Added more checks to sshprint commandline arguments
+- Some light refactoring
+
+### **Updated**
+- Expanded the documentation in POD - we now have
+ sane man pages
+
+### **Still Todo**
+- Add more verbosity printouts
+- Do further refactoring
+
## [2.03] - 2016.08.16
### **Fixes**
- Corrected incorrect variable reference for application version
@@ -39,7 +52,8 @@ Nothing to report...
### Fixed
- Fix regex in select printer dialog.
-[Unreleased]: https://github.com/hv15/sshprint/compare/2.03...HEAD
+[Unreleased]: https://github.com/hv15/sshprint/compare/2.04...HEAD
+[2.04]: https://github.com/hv15/sshprint/compare/2.03...2.04
[2.03]: https://github.com/hv15/sshprint/compare/2.02...2.03
[2.02]: https://github.com/hv15/sshprint/compare/2.01...2.02
[2.01]: https://github.com/hv15/sshprint/compare/2.00...2.01
diff --git a/PKGBUILD b/PKGBUILD
index c27467e97c12..1b53bde2d368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Hans-Nikolai Viessmann <hv15@hw.ac.uk>
_project=sshprint
pkgname=$_project
-pkgver=2.03
+pkgver=2.04
pkgrel=1
pkgdesc="A Perl script to print local files on remote printers using SSH"
arch=('any')
url="https://github.com/hv15/$_project"
license=('MIT')
-depends=('perl>=5.22.0' 'openssh')
+depends=('perl>=5.22.0' 'openssh' 'perl-log-log4perl' 'perl-config-simple' 'perl-net-openssh')
conflicts=('sshprint<=1.6.3')
options=(!emptydirs)
changelog='CHANGELOG.md'
install=sshprint.install
source=("https://github.com/hv15/${_project}/archive/${pkgver}.tar.gz")
-md5sums=('239989d27219722bc2229b13501cb555')
+md5sums=('8790659a28cb4e64fc16b860f3e6e38f')
build() {
cd "$srcdir/${pkgname}-$pkgver"