summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph R. Quinn2019-10-28 13:44:34 -0400
committerJoseph R. Quinn2019-10-28 13:44:34 -0400
commit65ed1e77d3150a35a6a63e93249bb9dea4b9fefc (patch)
treef8c7feafd9cc539345a727426ba4236ee0dba0ce
downloadaur-65ed1e77d3150a35a6a63e93249bb9dea4b9fefc.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD29
-rw-r--r--psr.ini1
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..729a6d5ddfc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php-psr
+ pkgdesc = PHP extension providing the accepted PSR interfaces.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/jbboehr/php-psr
+ arch = any
+ license = GPL
+ makedepends = gcc>=4.4
+ depends = php
+ provides = php-psr
+ backup = etc/php/conf.d/psr.ini
+ source = https://github.com/jbboehr/php-psr/archive/v0.7.0.tar.gz
+ source = psr.ini
+ sha1sums = 9d44acc24a37e90e08cf74c02817a80d750cd1b9
+ sha1sums = a5111be5b2ea0c2be3a2b6795be6f47d60dc0d77
+
+pkgname = php-psr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccdadf693590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ec0b266b5da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Joseph R. Quinn <quinn period joseph r at gmail dot com
+pkgname=php-psr
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="PHP extension providing the accepted PSR interfaces."
+arch=('any')
+url="https://github.com/jbboehr/php-psr"
+license=('GPL')
+depends=('php')
+makedepends=('gcc>=4.4')
+provides=("$pkgname")
+backup=('etc/php/conf.d/psr.ini')
+source=("https://github.com/jbboehr/$pkgname/archive/v$pkgver.tar.gz"
+ 'psr.ini')
+sha1sums=('9d44acc24a37e90e08cf74c02817a80d750cd1b9'
+ 'a5111be5b2ea0c2be3a2b6795be6f47d60dc0d77')
+
+build() {
+ cd "$pkgname-$pkgver"
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 "$srcdir/psr.ini" "$pkgdir/etc/php/conf.d/psr.ini"
+}
diff --git a/psr.ini b/psr.ini
new file mode 100644
index 000000000000..d5b18f58f56f
--- /dev/null
+++ b/psr.ini
@@ -0,0 +1 @@
+extension=psr.so \ No newline at end of file