summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-06-11 20:27:18 +0200
committerAndré Fettouhi2015-06-11 20:27:18 +0200
commit661a9773157beee1fd9cef340aea621ba2673b71 (patch)
treebf536cf4660219b83a3c5329ddfc778e59153e00
downloadaur-661a9773157beee1fd9cef340aea621ba2673b71.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--configurator5
-rw-r--r--gog-the-witcher-2-assassins-of-kings4
-rw-r--r--gog-the-witcher-2-configurator.desktop9
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..775a38742175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gog-the-witcher-2-assassins-of-kings
+ pkgdesc = The second installment in the RPG saga about the Witcher, Geralt of Rivia. GOG version (Linux installer).
+ pkgver = 1.2.0.7
+ pkgrel = 1
+ url = http://www.gog.com/game/the_witcher_2
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = lib32-sdl2
+ depends = lib32-freetype2
+ depends = lib32-sdl2_image
+ depends = lib32-gtk2
+ source = local://gog_the_witcher_2_assassins_of_kings_1.2.0.7.tar.gz
+ source = gog-the-witcher-2-assassins-of-kings
+ source = gog-the-witcher-2-configurator.desktop
+ source = configurator
+ sha256sums = 9139bae265de692b5b3bbe9466ca7eff3b006f7a51e2df13cf2d86b2b247fadf
+ sha256sums = ece02677bb029e69f8248018873fbfec34f9f6eb43f42966842f4f9ac80e83f0
+ sha256sums = 52344cc8e6dfdef1034658412ba4cdc3fd56064762675f2a39403d21276851b7
+ sha256sums = 31d9f5e327f18eadb1a2a6825e2c773de22b2d6594451649edb95c5c968bf26e
+
+pkgname = gog-the-witcher-2-assassins-of-kings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43e04d4fba19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+# Contributor: mirandir <mirandir[at)orange(dot]com>
+
+pkgname=gog-the-witcher-2-assassins-of-kings
+pkgver=1.2.0.7
+pkgrel=1
+pkgdesc="The second installment in the RPG saga about the Witcher, Geralt of Rivia. GOG version (Linux installer)."
+arch=("i686" "x86_64")
+
+if [[ $CARCH == i686 ]]; then
+ depends=(sdl2 freetype2 sdl2_image gtk2)
+else
+ depends=(lib32-sdl2 lib32-freetype2 lib32-sdl2_image lib32-gtk2)
+fi
+
+url="http://www.gog.com/game/the_witcher_2"
+license=("custom")
+groups=("games")
+source=("local://gog_the_witcher_2_assassins_of_kings_${pkgver}.tar.gz" "gog-the-witcher-2-assassins-of-kings" "gog-the-witcher-2-configurator.desktop" "configurator")
+sha256sums=('9139bae265de692b5b3bbe9466ca7eff3b006f7a51e2df13cf2d86b2b247fadf'
+ 'ece02677bb029e69f8248018873fbfec34f9f6eb43f42966842f4f9ac80e83f0'
+ '52344cc8e6dfdef1034658412ba4cdc3fd56064762675f2a39403d21276851b7'
+ '31d9f5e327f18eadb1a2a6825e2c773de22b2d6594451649edb95c5c968bf26e')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/the-witcher-2-assassins-of-kings/
+
+ mv "${srcdir}"/The\ Witcher\ 2\ Assassins\ Of\ Kings/* "${pkgdir}"/opt/gog/the-witcher-2-assassins-of-kings/
+
+ install -Dm644 "${pkgdir}"/opt/gog/the-witcher-2-assassins-of-kings/support/gog-the-witcher-2-assassins-of-kings-primary.desktop "${pkgdir}"/usr/share/applications/gog-the-witcher-2-assassins-of-kings.desktop
+ install -Dm644 "${pkgdir}"/opt/gog/the-witcher-2-assassins-of-kings/support/gog-the-witcher-2-assassins-of-kings.png "${pkgdir}"/usr/share/pixmaps/gog-the-witcher-2-assassins-of-kings.png
+ # install .desktop file for the configurator
+ install -Dm644 "${srcdir}"/gog-the-witcher-2-configurator.desktop "${pkgdir}"/usr/share/applications/gog-the-witcher-2-configurator.desktop
+
+ install -Dm644 "${pkgdir}"/opt/gog/the-witcher-2-assassins-of-kings/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+
+ install -Dm755 "${srcdir}/gog-the-witcher-2-assassins-of-kings" "${pkgdir}/usr/bin/gog-the-witcher-2-assassins-of-kings"
+ install -Dm755 "${srcdir}/configurator" "${pkgdir}/usr/bin/gog-the-witcher-2-configurator"
+}
diff --git a/configurator b/configurator
new file mode 100644
index 000000000000..bed82b7611b5
--- /dev/null
+++ b/configurator
@@ -0,0 +1,5 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/the-witcher-2-assassins-of-kings"
+
+cd "$gogdir"/game/
+./configurator
diff --git a/gog-the-witcher-2-assassins-of-kings b/gog-the-witcher-2-assassins-of-kings
new file mode 100644
index 000000000000..d4696e4c8c2a
--- /dev/null
+++ b/gog-the-witcher-2-assassins-of-kings
@@ -0,0 +1,4 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/the-witcher-2-assassins-of-kings"
+
+"$gogdir"/start.sh
diff --git a/gog-the-witcher-2-configurator.desktop b/gog-the-witcher-2-configurator.desktop
new file mode 100644
index 000000000000..6f8ec9729d95
--- /dev/null
+++ b/gog-the-witcher-2-configurator.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=The Witcher 2 Assassins Of Kings - Configurator
+Comment=The Witcher 2 Assassins Of Kings - Configurator (GOG.com)
+Exec=gog-the-witcher-2-configurator
+Icon=/opt/gog/the-witcher-2-assassins-of-kings/game/linux/icons/witcher2-configurator.png
+Terminal=false
+Type=Application
+Categories=Game;