summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 15:34:37 +0300
committerViktor Drobot2020-01-31 15:34:37 +0300
commit6627475f6d5993eae71cd00eb848ee34283c9bff (patch)
tree5a7631daa4bc216093bb68b99a50c7d96561078f
parentc869f33ac982b9ecc9d37cfe21fbaeb32db1fcae (diff)
downloadaur-6627475f6d5993eae71cd00eb848ee34283c9bff.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23e6623b8968..611b2a740bc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,14 @@ pkgbase = r-bitops
pkgdesc = Bitwise Operations
pkgver = 1.0.6
pkgrel = 1
- url = http://cran.r-project.org/web/packages/bitops/index.html
+ url = https://cran.r-project.org/package=bitops
+ arch = i686
arch = x86_64
+ license = GPL2
license = GPL3
+ makedepends = gcc
depends = r
- source = http://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
+ source = https://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
md5sums = fba16485a51b1ccd354abde5816b6bdd
pkgname = r-bitops
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6ae0b18a1f6c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 6f5473ee5e83..56723a56ddd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,29 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
+
+_cranname=bitops
+_cranver=1.0-6
pkgname=r-bitops
-_cran_name=bitops
-_pkgver=1.0-6
-pkgver=${_pkgver//-/.}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Bitwise Operations"
-arch=('x86_64')
-url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
-license=('GPL3')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${_pkgver}.tar.gz")
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL2 GPL3)
+depends=(r)
+makedepends=(gcc)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('fba16485a51b1ccd354abde5816b6bdd')
+build(){
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}