summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUncle Hunto2016-01-13 18:31:06 -0800
committerUncle Hunto2016-01-13 18:31:06 -0800
commit6627dd5768d13ec93af62ab6a174fcf51c2dcfe5 (patch)
tree3ae6afc6faecddb8837e3c62072c81af9dfaf9d7
downloadaur-6627dd5768d13ec93af62ab6a174fcf51c2dcfe5.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rw-r--r--qbittorrent.install13
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..430587e9d4db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Thu Jan 14 02:28:24 UTC 2016
+pkgbase = qbittorrent-stable-git
+ pkgdesc = An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar. Built from source.
+ pkgver = 3.3.1.r0.gd753988
+ pkgrel = 1
+ url = http://www.qbittorrent.org
+ install = qbittorrent.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ license = GPL
+ makedepends = boost
+ makedepends = git
+ makedepends = qt5-tools
+ depends = libtorrent-rasterbar
+ depends = qt5-base
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ optdepends = python: needed for torrent search tab
+ source = qbittorrent::git+https://github.com/qbittorrent/qBittorrent.git#branch=v3_3_x
+ sha256sums = SKIP
+
+pkgname = qbittorrent-stable-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10eaf7dcad62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Jkkyll Wu <adaptee at gmail [dot] com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+
+pkgname=qbittorrent-stable-git
+pkgver=3.3.1.r0.gd753988
+pkgrel=1
+pkgdesc="An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar. Built from source."
+arch=('i686' 'x86_64')
+url="http://www.qbittorrent.org"
+license=('custom' 'GPL')
+depends=('libtorrent-rasterbar' 'qt5-base' 'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('boost' 'git' 'qt5-tools')
+optdepends=('python: needed for torrent search tab')
+install=${pkgname%-*-*}.install
+source=("${pkgname%-*-*}"::"git+https://github.com/qbittorrent/qBittorrent.git#branch=v3_3_x")
+sha256sums=('SKIP')
+pkgver() {
+ cd $srcdir/${pkgname%-*-*}
+ git describe --long --tags | sed 's/^release-//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd $srcdir/${pkgname%-*-*}
+ ./configure --prefix=/usr
+ make -j$(nproc)
+}
+
+package() {
+ cd $srcdir/${pkgname%-*-*}
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/qbittorrent.install b/qbittorrent.install
new file mode 100644
index 000000000000..3f676f0a189f
--- /dev/null
+++ b/qbittorrent.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}