summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2019-10-31 14:54:27 +0100
committerfrederik2019-10-31 14:54:27 +0100
commit662ab871e9a3e87724449899c8301c8affdd9d76 (patch)
treeb158bd38fdca6874f05f34692a01dce1a45a0d2e
parent63eddfc291bb1d09db2167aa7202d38e9f7bd738 (diff)
downloadaur-662ab871e9a3e87724449899c8301c8affdd9d76.tar.gz
gtkhotkey: PKGBUILD review by svenstaro
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD31
-rw-r--r--fix-glib-and-docpath.patch48
3 files changed, 63 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bed82ec9b745..30af5a232bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,9 @@ pkgbase = gtkhotkey
makedepends = intltool
depends = gtk2
source = http://launchpad.net/gtkhotkey/0.2/0.2.1/+download/gtkhotkey-0.2.1.tar.gz
- md5sums = bfdc73e68e9adbe0d506d31a25862914
+ source = fix-glib-and-docpath.patch
+ sha512sums = 7f7e1b9bd94ff806d98277f2dafbf5b6569efdc6f0367a83e885d38584a8f6e098f31d0f03b080f2ca76394eb73e43f9da07e0d944a2e6443a55d9f2e8fee324
+ sha512sums = 2069f269b5abcd204a00a2e1ced78699e1acf7e7594ff660771911f711e4c3a36931378d32ac97b9fd43216e2522bec2f27e6c8274f2a599999ec8bb6a793f63
pkgname = gtkhotkey
diff --git a/PKGBUILD b/PKGBUILD
index a1f47a3c3e5c..416884a1735e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alessio Sergi <asergi at archlinux dot us>
# Contributor: Gaute Hope <eg@gaute.vetsj.com>
# Contributor: Marcos Heredia <chelqo@gmail.com>
-
+
pkgname=gtkhotkey
pkgver=0.2.1
pkgrel=9
@@ -14,26 +14,19 @@ url="https://launchpad.net/gtkhotkey"
license=('LGPL3')
depends=('gtk2')
makedepends=('intltool')
-source=("http://launchpad.net/$pkgname/0.2/$pkgver/+download/$pkgname-$pkgver.tar.gz")
-md5sums=('bfdc73e68e9adbe0d506d31a25862914')
-
+source=("http://launchpad.net/$pkgname/0.2/$pkgver/+download/$pkgname-$pkgver.tar.gz"
+ fix-glib-and-docpath.patch)
+sha512sums=('7f7e1b9bd94ff806d98277f2dafbf5b6569efdc6f0367a83e885d38584a8f6e098f31d0f03b080f2ca76394eb73e43f9da07e0d944a2e6443a55d9f2e8fee324'
+ '2069f269b5abcd204a00a2e1ced78699e1acf7e7594ff660771911f711e4c3a36931378d32ac97b9fd43216e2522bec2f27e6c8274f2a599999ec8bb6a793f63')
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # doc path fix
- sed -i '/gtkhotkeydocdir/s/\${prefix}/\${datadir}/g' Makefile.{am,in}
-
- # glib2 fix
- sed -i 's|glib/gquark\.h|glib.h|' src/gtk-hotkey-error.h
- sed -i 's|glib/gtypes\.h|glib.h|' src/x11/tomboykeybinder.h
-
- ./configure --prefix=/usr \
- --disable-static
+ cd ${pkgname}-${pkgver}
+ patch -p0 < "${srcdir}"/fix-glib-and-docpath.patch
+ ./configure --prefix=/usr --disable-static
make
}
-
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}"/ install
}
diff --git a/fix-glib-and-docpath.patch b/fix-glib-and-docpath.patch
new file mode 100644
index 000000000000..be4566d2379a
--- /dev/null
+++ b/fix-glib-and-docpath.patch
@@ -0,0 +1,48 @@
+diff --git Makefile.am Makefile.am
+--- Makefile.am 2009-09-03 22:52:49.000000000 +0200
++++ Makefile.am 2019-10-28 18:18:35.544582709 +0100
+@@ -11,7 +11,7 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = gtkhotkey-1.0.pc
+
+-gtkhotkeydocdir = ${prefix}/doc/gtkhotkey
++gtkhotkeydocdir = ${datadir}/doc/gtkhotkey
+ gtkhotkeydoc_DATA = \
+ README \
+ COPYING \
+diff --git Makefile.in Makefile.in
+--- Makefile.in 2009-09-03 22:53:33.000000000 +0200
++++ Makefile.in 2019-10-28 18:18:35.544582709 +0100
+@@ -246,7 +246,7 @@
+ SUBDIRS = src po test doc
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = gtkhotkey-1.0.pc
+-gtkhotkeydocdir = ${prefix}/doc/gtkhotkey
++gtkhotkeydocdir = ${datadir}/doc/gtkhotkey
+ gtkhotkeydoc_DATA = \
+ README \
+ COPYING \
+diff --git src/gtk-hotkey-error.h src/gtk-hotkey-error.h
+--- src/gtk-hotkey-error.h 2009-09-03 22:52:49.000000000 +0200
++++ src/gtk-hotkey-error.h 2019-10-28 18:18:35.544582709 +0100
+@@ -23,7 +23,7 @@
+ #ifndef __GTK_HOTKEY_ERROR_H__
+ #define __GTK_HOTKEY_ERROR_H__
+
+-#include <glib/gquark.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff --git src/x11/tomboykeybinder.h src/x11/tomboykeybinder.h
+--- src/x11/tomboykeybinder.h 2009-09-03 22:52:49.000000000 +0200
++++ src/x11/tomboykeybinder.h 2019-10-28 18:18:35.547916050 +0100
+@@ -2,7 +2,7 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+