summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2019-10-30 17:51:38 +0000
committerGergely Imreh2019-10-30 17:51:38 +0000
commit662fde30f4a9944148afc7a26fdbeee9a857ce42 (patch)
tree221011ea1b857e3bd1dc10800cec24cfd4318d44
parente608b84a890072c63a77a8575018b42014240034 (diff)
downloadaur-662fde30f4a9944148afc7a26fdbeee9a857ce42.tar.gz
Bump to 18.9.10
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e85d22539fa..dfff675e0b16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = balena-engine
pkgdesc = A Moby-based container engine for the Internet of Things
- pkgver = 18.9.7
+ pkgver = 18.9.10
pkgrel = 1
epoch = 1
url = https://www.balena.io/
@@ -23,7 +23,7 @@ pkgbase = balena-engine
optdepends = lxc: lxc backend support
options = !strip
options = !buildflags
- source = git+https://github.com/balena-os/balena-engine.git#tag=v18.9.7
+ source = git+https://github.com/balena-os/balena-engine.git#tag=v18.9.10
source = balena-engine.sysusers
source = 80-balena-engine.rules
source = balena-engine.service.patch
diff --git a/PKGBUILD b/PKGBUILD
index e7b738ac4a80..b8ffef174ad0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Gegrely Imreh <imrehg@gmail.com>
pkgname=balena-engine
-pkgver=18.9.7
+pkgver=18.9.10
pkgrel=1
epoch=1
pkgdesc='A Moby-based container engine for the Internet of Things'
@@ -41,10 +41,14 @@ build() {
}
package() {
-
- ### engine
- for f in "${srcdir}/${pkgname}/bundles/binary-balena/"* ; do
- install -Dm755 "${f}" -t "${pkgdir}/usr/bin/"
+ # The engine files
+ mkdir -p "${pkgdir}/usr/bin/"
+ for artifact in "${srcdir}/${pkgname}/bundles/binary-balena/"* ; do
+ if [ ! -L "${artifact}" ]; then
+ install -Dm755 "${artifact}" -t "${pkgdir}/usr/bin/"
+ else
+ cp -P "${artifact}" "${pkgdir}/usr/bin/"
+ fi
done
# systemd