summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Littley2017-03-11 11:56:12 +0000
committerSamuel Littley2017-03-11 11:56:18 +0000
commit6630d99d107766f57b75a6fa914ad04c7d530da8 (patch)
treed9ced2f570bc533efce42c5aa55997708ba6f290
parent9c0d91e4d003aa7d07292f524de00001d8cfec7d (diff)
downloadaur-6630d99d107766f57b75a6fa914ad04c7d530da8.tar.gz
Use wrapper script to LD_PRELOAD libcurl-compat
Makes the package easier to use for people who don't use .desktop files.
-rw-r--r--.SRCINFO8
-rw-r--r--GitKraken.desktop2
-rw-r--r--PKGBUILD11
-rw-r--r--gitkraken.sh3
4 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e2151a97b37..652a16ec1daf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Mar 9 16:58:31 UTC 2017
+# Sat Mar 11 11:55:53 UTC 2017
pkgbase = gitkraken
pkgdesc = The intuitive, fast, and beautiful cross-platform Git client.
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.gitkraken.com/
arch = x86_64
license = custom
@@ -20,10 +20,12 @@ pkgbase = gitkraken
source = GitKraken.desktop
source = gitkraken.png
source = eula.html
+ source = gitkraken.sh
md5sums = 60ef26ca66f7d73ae29e53b557b69350
- md5sums = ecef298bed1178d60cf0dd75c4700205
+ md5sums = 55f11789f5a9ee9fc4989d0f06eee260
md5sums = 04987b933d551d15c0813111d715bb9e
md5sums = e9ba6663e5f1f92cae31beb0074e8c6c
+ md5sums = e3063947b063aaccf4dc17ed47437ea8
pkgname = gitkraken
diff --git a/GitKraken.desktop b/GitKraken.desktop
index 6a475eae3e4f..1814363c3b48 100644
--- a/GitKraken.desktop
+++ b/GitKraken.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=GitKraken
Comment=Unleash your repo
-Exec=bash -c "LD_PRELOAD=/usr/lib/libcurl.so.3 gitkraken"
+Exec="gitkraken"
Icon=gitkraken
Terminal=false
Type=Application
diff --git a/PKGBUILD b/PKGBUILD
index bcea6d79b934..29e118d60699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Tim Kleinschmidt <tim.kleinschmidt@gmail.com>
# Contributor: Marcin Wieczorek <marcin@marcin.co>
# Contributor: Jean-Pier Brochu <jeanpier.brochu@gmail.com>
+# Contributor: Samuel Littley <samuel@samuellittley.me>
pkgname=gitkraken
-pkgrel=1
+pkgrel=2
pkgver=2.2.0
pkgdesc="The intuitive, fast, and beautiful cross-platform Git client."
url="http://www.gitkraken.com/"
@@ -19,11 +20,13 @@ source=(
"GitKraken.desktop"
"gitkraken.png"
"eula.html"
+ "gitkraken.sh"
)
md5sums=('60ef26ca66f7d73ae29e53b557b69350'
- 'ecef298bed1178d60cf0dd75c4700205'
+ '55f11789f5a9ee9fc4989d0f06eee260'
'04987b933d551d15c0813111d715bb9e'
- 'e9ba6663e5f1f92cae31beb0074e8c6c')
+ 'e9ba6663e5f1f92cae31beb0074e8c6c'
+ 'e3063947b063aaccf4dc17ed47437ea8')
package() {
install -d "$pkgdir"/opt
@@ -33,8 +36,8 @@ package() {
chmod 755 "$pkgdir"/opt/gitkraken/gitkraken
install -d "$pkgdir"/usr/bin
- ln -s ../../opt/gitkraken/gitkraken "$pkgdir"/usr/bin/gitkraken
+ install -D -m755 "./gitkraken.sh" "${pkgdir}/usr/bin/gitkraken"
install -D -m644 "./eula.html" "${pkgdir}/usr/share/licenses/${pkgname}/eula.html"
install -D -m644 "./GitKraken.desktop" "${pkgdir}/usr/share/applications/GitKraken.desktop"
install -D -m644 "./gitkraken.png" "${pkgdir}/usr/share/pixmaps/gitkraken.png"
diff --git a/gitkraken.sh b/gitkraken.sh
new file mode 100644
index 000000000000..545d403cd6ca
--- /dev/null
+++ b/gitkraken.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+LD_PRELOAD=/usr/lib/libcurl.so.3 /opt/gitkraken/gitkraken