summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2023-03-17 22:49:13 -0500
committeracxz2023-03-17 22:49:13 -0500
commit66538a5399bf898e32d475a7152f77c023611e41 (patch)
treec57512553a9738df8e718bc6704b402b2e0ff600
parentb8db295b8df6b5a9e99ec2970d98e134b00fa236 (diff)
downloadaur-66538a5399bf898e32d475a7152f77c023611e41.tar.gz
upgpkg: qgroundcontrol 4.2.5-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 3 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 258b09a9c52c..013a17024ea2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgroundcontrol
pkgdesc = Micro air vehicle ground control station.
- pkgver = 4.2.4
+ pkgver = 4.2.5
pkgrel = 1
url = https://github.com/mavlink/qgroundcontrol
arch = x86_64
@@ -44,7 +44,7 @@ pkgbase = qgroundcontrol
depends = qt5-tools
depends = qt5-wayland
depends = qt5-x11extras
- source = qgroundcontrol-4.2.4::git+https://github.com/mavlink/qgroundcontrol.git#tag=v4.2.4
+ source = qgroundcontrol-4.2.5::git+https://github.com/mavlink/qgroundcontrol.git#tag=v4.2.5
source = qgroundcontrol-GpsDrivers::git+https://github.com/PX4/GpsDrivers.git
source = qgroundcontrol-c_library_v2::git+https://github.com/mavlink/c_library_v2.git
source = qgroundcontrol-android_openssl::git+https://github.com/Auterion/android_openssl.git
@@ -53,8 +53,6 @@ pkgbase = qgroundcontrol
source = qgroundcontrol-libevents::git+https://github.com/mavlink/libevents.git
source = qgroundcontrol-eigen::git+https://gitlab.com/libeigen/eigen.git
source = qgroundcontrol-qmdnsengine::git+https://github.com/patrickelectric/qmdnsengine.git
- source = gst-volatile.patch::https://patch-diff.githubusercontent.com/raw/mavlink/gst-plugins-good/pull/1.patch
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 470f3e3b76c6..1f9dcfbe664e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: K. Morton <pryre.dev@outlook.com>
# Contributor: Anselmo L. S. Melo <anselmo.melo@intel.com>
pkgname=qgroundcontrol
-pkgver=4.2.4
+pkgver=4.2.5
pkgrel=1
pkgdesc="Micro air vehicle ground control station."
arch=('x86_64')
@@ -58,7 +58,6 @@ source=("${pkgname}-${pkgver}::git+https://github.com/mavlink/qgroundcontrol.git
"${pkgname}-libevents::git+https://github.com/mavlink/libevents.git"
"${pkgname}-eigen::git+https://gitlab.com/libeigen/eigen.git"
"${pkgname}-qmdnsengine::git+https://github.com/patrickelectric/qmdnsengine.git"
- "gst-volatile.patch::https://patch-diff.githubusercontent.com/raw/mavlink/gst-plugins-good/pull/1.patch"
)
sha256sums=('SKIP'
@@ -70,11 +69,9 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
prepare() {
-
cd "$srcdir/${pkgname}-${pkgver}"
git submodule init
@@ -89,21 +86,16 @@ prepare() {
git config submodule."libs/qmdnsengine".url "${srcdir}/${pkgname}"-qmdnsengine
git -c protocol.file.allow=always submodule update --init --recursive
-
- cd "${srcdir}/${pkgname}-${pkgver}/libs/qmlglsink/gst-plugins-good"
- patch --strip=1 < "${srcdir}/gst-volatile.patch"
}
build() {
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
-
cd "$srcdir/${pkgname}-${pkgver}/build"
qmake ..
make
}
package() {
-
mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/bin" "${pkgdir}/usr/share/applications"
cp -r "${srcdir}/${pkgname}-${pkgver}/build/staging" "${pkgdir}/opt/${pkgname}"
cp "${srcdir}/${pkgname}-${pkgver}/resources/icons/qgroundcontrol.png" "${pkgdir}/opt/${pkgname}"