summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-08-02 11:34:49 +0200
committerChristopher Arndt2019-08-02 11:34:49 +0200
commit666d692e5dd3b64e2c6b768bff681bfe754dbc70 (patch)
treefe91142045cf812e590acaff901c6712eb573a20
parent41af94a5ade43473f62943dcf5b1d566ffbe0588 (diff)
downloadaur-666d692e5dd3b64e2c6b768bff681bfe754dbc70.tar.gz
New upstream version 1.5.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e94f7e5fb8ba..c6ddfc8970d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gpiozero
pkgdesc = A simple interface to GPIO devices with Raspberry Pi
- pkgver = 1.5.0
+ pkgver = 1.5.1
pkgrel = 1
url = https://github.com/RPi-Distro/python-gpiozero
arch = any
@@ -9,8 +9,8 @@ pkgbase = python-gpiozero
depends = python-setuptools
optdepends = python-spidev: for SPI access
optdepends = python-rpi.gpio: for Raspberry Pi GPIO pin access via RPi.GPIO library
- source = python-gpiozero-1.5.0.tar.gz::https://github.com/RPi-Distro/python-gpiozero/archive/v1.5.0.tar.gz
- sha256sums = 179a773e838a3f091d8585f919ab7e702abb777d7d7a7e6df1bf48cae53083a0
+ source = python-gpiozero-1.5.1.tar.gz::https://github.com/RPi-Distro/python-gpiozero/archive/v1.5.1.tar.gz
+ sha256sums = 8cb9824fe1b08e7935de03899455e20ce2c242e4cebb0c954c274c48059f6ea5
pkgname = python-gpiozero
diff --git a/PKGBUILD b/PKGBUILD
index 8e014c5f6cae..a3acb41dcf62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Giampaolo Mancini <giampaolo@trampolineup.com>
pkgname=python-gpiozero
-pkgver=1.5.0
+pkgver=1.5.1
pkgrel=1
pkgdesc='A simple interface to GPIO devices with Raspberry Pi'
arch=('any')
@@ -14,16 +14,16 @@ optdepends=(
)
depends=('python-colorzero' 'python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/RPi-Distro/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('179a773e838a3f091d8585f919ab7e702abb777d7d7a7e6df1bf48cae53083a0')
+sha256sums=('8cb9824fe1b08e7935de03899455e20ce2c242e4cebb0c954c274c48059f6ea5')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname//python-/}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname//python-/}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
}