summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2023-01-29 21:13:40 +1300
committerThomas Booker2023-01-29 21:14:22 +1300
commit668e36254855af5d3750bc826bf043efaae80ad6 (patch)
tree04bf1249135d80f9529ed35cd42fa59350ba9b69
parentd681615593e28543ff2fc76bfe6bd6586759aed6 (diff)
downloadaur-668e36254855af5d3750bc826bf043efaae80ad6.tar.gz
Use git and fix Subproject error
The that was fix was: "ERROR: Subproject exists but has no meson.build file"
-rw-r--r--PKGBUILD30
1 files changed, 26 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82a2dc476b97..d468bed987cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Maintainer: Thomas Booker (CoderThomasB) <tw.booker@outlook.com>
+# Contributor: <reg-archlinux AT klein DOT tuxli DOT ch>
# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Sam Whited <sam@samwhited.com>
@@ -19,12 +20,33 @@ makedepends=(
gobject-introspection
meson
vala
+ git
+ # requered for man docs
+ # python-docutils
)
-source=("${url}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-b2sums=('088047712fc1cce219bd1fe6b7f82883eb9806ff6b14f932012f42dc13ff12958a807b0a64e88c56bd1f89b4e4da4c0b78400960fc71f3a7ac4c3e78c14f8341')
+
+_tag=fca952f813124110c9dabd766e85255992187c32
+source=(
+ "git+${url}.git#tag=${_tag}"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --tags | sed 's/^v//'
+}
+
+prepare() {
+ cd "${pkgname}"
+
+ git submodule init
+ git submodule update
+}
build() {
- arch-meson "${pkgname}-v${pkgver}" build -Dgtk_doc=true -Dman=true
+ arch-meson "${pkgname}" build -Dgtk_doc=false -Dman=false -Dtests=true -Ddaemon=true
meson compile -C build
}