summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2015-07-08 11:12:00 -0400
committerConnor Behan2015-07-08 11:12:00 -0400
commit669dcca53dd8e1a2c4dc7755559d33f80d056cbc (patch)
tree135fec3e2b8e2221625ab985382483bc70b41f6b
downloadaur-669dcca53dd8e1a2c4dc7755559d33f80d056cbc.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23e3904300d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = scscp
+ pkgdesc = C library for the Symbolic Computation Software Composibility Protocol
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://www.imcce.fr/Equipes/ASD/trip/scscp/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libxml2
+ source = http://www.imcce.fr/Equipes/ASD/trip/scscp/download/scscp-1.0.1.tar.gz
+ md5sums = e00818acf6ebe33002c407896636cd93
+
+pkgname = scscp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4b933934dc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Connor Behan <connor.behan@gmail.com>
+# Contributor: Rémy Oudompheng <remy@archlinux.org>
+
+pkgname=scscp
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="C library for the Symbolic Computation Software Composibility Protocol"
+arch=('i686' 'x86_64')
+url="http://www.imcce.fr/Equipes/ASD/trip/scscp/"
+license=('custom')
+depends=('libxml2')
+source=(http://www.imcce.fr/Equipes/ASD/trip/scscp/download/scscp-$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+ #make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING_CECILL_C.LIB $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums=('e00818acf6ebe33002c407896636cd93')