summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Lundberg2015-09-18 17:27:59 +0200
committerEmil Lundberg2015-09-18 17:27:59 +0200
commit66a753882e66788866ac7de401e0b3c748014d2f (patch)
treee574978634f425f76f8a72695ce319147744ced9
parentb77afc907c3a735144db31cb3199df6b593fe690 (diff)
downloadaur-66a753882e66788866ac7de401e0b3c748014d2f.tar.gz
Move previously splitted package headers to top of PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07fb6cb0afd3..323474112d45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
pkgbase = icedtea-web-jre32
+ pkgdesc = Free web browser plugin to run applets written in Java and an implementation of Java Web Start (uses 32-bit JRE)
pkgver = 1.6.1
pkgrel = 1
url = http://icedtea.classpath.org/wiki/IcedTea-Web
+ install = install_icedtea-web-jre32.sh
arch = i686
arch = x86_64
license = GPL2
@@ -15,9 +17,13 @@ pkgbase = icedtea-web-jre32
makedepends = firefox
makedepends = epiphany
depends = bin32-jre
+ depends = java-runtime-openjdk
+ depends = desktop-file-utils
optdepends = rhino: for using proxy auto config files
optdepends = icedtea-web-doc: Documentation
+ provides = java-web-start
conflicts = icedtea-web
+ replaces = icedtea-web-java7
noextract = icedtea-web-1.6.1.tar.gz
source = http://icedtea.classpath.org/download/source/icedtea-web-1.6.1.tar.gz
source = fix-package-info.patch
@@ -25,10 +31,4 @@ pkgbase = icedtea-web-jre32
sha256sums = 3da531a0b2ba99152fe9410591ade01b6ea63a926cc36f3fa0ab39955708940c
pkgname = icedtea-web-jre32
- pkgdesc = Free web browser plugin to run applets written in Java and an implementation of Java Web Start
- install = install_icedtea-web-jre32.sh
- depends = java-runtime-openjdk
- depends = desktop-file-utils
- provides = java-web-start
- replaces = icedtea-web-java7
diff --git a/PKGBUILD b/PKGBUILD
index 9e2a00a57ac5..a51a39dc188e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,20 @@ pkgname=icedtea-web-jre32
conflicts=('icedtea-web')
pkgver=1.6.1
pkgrel=1
+pkgdesc='Free web browser plugin to run applets written in Java and an implementation of Java Web Start (uses 32-bit JRE)'
arch=('i686' 'x86_64')
url='http://icedtea.classpath.org/wiki/IcedTea-Web'
license=('GPL2')
-depends=('bin32-jre')
+depends=('bin32-jre' 'java-runtime-openjdk' 'desktop-file-utils')
makedepends=('java-environment-openjdk' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'junit' 'bin32-jdk'
'firefox' 'epiphany')
optdepends=('rhino: for using proxy auto config files'
'icedtea-web-doc: Documentation'
)
+provides=('java-web-start')
+replaces=('icedtea-web-java7')
+install=install_${pkgname}.sh
+
# Due to broken path names in the tarball that fails with LANG=C in our chroot
noextract=${_pkgbase}-${pkgver}.tar.gz
source=(
@@ -54,13 +59,6 @@ build() {
package() {
-
- pkgdesc='Free web browser plugin to run applets written in Java and an implementation of Java Web Start'
- depends=('java-runtime-openjdk' 'desktop-file-utils')
- provides=('java-web-start')
- replaces=('icedtea-web-java7')
- install=install_${pkgname}.sh
-
cd "${srcdir}"/${_pkgbase}-${pkgver}
# possible make target (see bottom of Makefile.am: install-exec-local install-data-local
make DESTDIR="${pkgdir}" install-exec-local install-data-local