summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2021-05-20 14:49:07 +0700
committerBuildTools2021-05-20 14:49:07 +0700
commit66a96f9575318d2f5899aeb2ba0ae08f5937a24b (patch)
tree1b469cd18ceddae5e992b455318eee361bde29a7
parentd7919caecefe7bfccf1a9061853fea37614324ee (diff)
downloadaur-66a96f9575318d2f5899aeb2ba0ae08f5937a24b.tar.gz
Added disable-openexr.patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
-rw-r--r--gwyddion-2.58-disable-openexr.patch12
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12b04235b0be..2498c42c316f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gwyddion
pkgdesc = A data visualization and processing tool for scanning probe miscroscopy (SPM, i.e. AFM, STM, MFM, SNOM/NSOM, ...) and profilometry, useful also for general image and 2D data analysis
pkgver = 2.58
- pkgrel = 2
+ pkgrel = 3
url = http://gwyddion.net/
arch = i686
arch = x86_64
@@ -22,10 +22,11 @@ pkgbase = gwyddion
optdepends = libwebp: WebP format support for the image export
optdepends = libzip: import of APE DAX, NanoObserver, NanoScanTech, OpenGPS and Sensofar PLUX data files
optdepends = cfitsio: import of Flexible Image Transport System (FITS) files
- optdepends = openexr: import and export of OpenEXR HDR images
optdepends = hdf5: import of Ergo data files
source = http://downloads.sourceforge.net/sourceforge/gwyddion/gwyddion-2.58.tar.xz
+ source = gwyddion-2.58-disable-openexr.patch
sha256sums = d31367cd892e5b79c4b0eda8fb458403e67bd575a8aba1585e6df8d8e58ef52c
+ sha256sums = 5096afc6030ef2c39635ce33dec2af1c25b62865710a1aa91006d11ac1607bc4
pkgname = gwyddion
diff --git a/PKGBUILD b/PKGBUILD
index 283dc4401423..42904734c4ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=gwyddion
pkgver=2.58
-pkgrel=2
+pkgrel=3
pkgdesc="A data visualization and processing tool for scanning probe miscroscopy (SPM, i.e. AFM, STM, MFM, SNOM/NSOM, ...) and profilometry, useful also for general image and 2D data analysis"
url="http://gwyddion.net/"
license=("GPL")
@@ -19,10 +19,17 @@ optdepends=('libxml2: import of SPML and APE DAX data files'
'libwebp: WebP format support for the image export'
'libzip: import of APE DAX, NanoObserver, NanoScanTech, OpenGPS and Sensofar PLUX data files'
'cfitsio: import of Flexible Image Transport System (FITS) files'
- 'openexr: import and export of OpenEXR HDR images'
+# 'openexr: import and export of OpenEXR HDR images'
'hdf5: import of Ergo data files')
-source=(http://downloads.sourceforge.net/sourceforge/gwyddion/$pkgname-$pkgver.tar.xz)
-sha256sums=('d31367cd892e5b79c4b0eda8fb458403e67bd575a8aba1585e6df8d8e58ef52c')
+source=(http://downloads.sourceforge.net/sourceforge/gwyddion/$pkgname-$pkgver.tar.xz gwyddion-2.58-disable-openexr.patch)
+sha256sums=('d31367cd892e5b79c4b0eda8fb458403e67bd575a8aba1585e6df8d8e58ef52c'
+ '5096afc6030ef2c39635ce33dec2af1c25b62865710a1aa91006d11ac1607bc4')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ patch -Np2 -i "${srcdir}/gwyddion-2.58-disable-openexr.patch"
+}
build() {
cd $pkgname-$pkgver
diff --git a/gwyddion-2.58-disable-openexr.patch b/gwyddion-2.58-disable-openexr.patch
new file mode 100644
index 000000000000..a840617e6d71
--- /dev/null
+++ b/gwyddion-2.58-disable-openexr.patch
@@ -0,0 +1,12 @@
+diff -Naur src/gwyddion-2.58/modules/file/hdrimage.cc src_/gwyddion-2.58/modules/file/hdrimage.cc
+--- src/gwyddion-2.58/modules/file/hdrimage.cc 2020-08-26 20:06:48.000000000 +0700
++++ src_/gwyddion-2.58/modules/file/hdrimage.cc 2021-05-20 12:24:34.621284332 +0700
+@@ -40,6 +40,8 @@
+ #include <glib/gstdio.h>
+ #include <gtk/gtk.h>
+
++#undef HAVE_EXR
++
+ #ifdef HAVE_PNG
+ #include <png.h>
+ #endif