summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-05-15 17:04:14 +0200
committerMichel Zou2020-05-15 17:04:14 +0200
commit66ba533e4312b759ea1ebfc556e3feb3328cf0d3 (patch)
tree024951bbfc572a672e5eab6f9e9cd3045157f931
parentc5b15ccfc60e6b3f7c33966a50f8535ba0fde83f (diff)
downloadaur-66ba533e4312b759ea1ebfc556e3feb3328cf0d3.tar.gz
0.108.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 945b5f7d4447..593cd354d3ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = feelpp
pkgdesc = Finite Element Embedded Language and Library in C++
- pkgver = 0.107.0
+ pkgver = 0.108.0
pkgrel = 1
url = https://github.com/feelpp
- arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
@@ -18,7 +17,7 @@ pkgbase = feelpp
depends = glpk
depends = gsl
depends = python
- source = feelpp-0.107.0::git+https://github.com/feelpp/feelpp.git#tag=v0.107.0
+ source = feelpp-0.108.0::git+https://github.com/feelpp/feelpp.git#tag=v0.108.0
sha256sums = SKIP
pkgname = feelpp
diff --git a/PKGBUILD b/PKGBUILD
index 14940474a751..51afe3788775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
-# Contributor: Guillaume DOLLÉ <dolle.guillaume at gmail.com>
-# Contributor: George Eleftheriou <eleftg>
-
pkgname=feelpp
-pkgver=0.107.0
+pkgver=0.108.0
pkgrel=1
pkgdesc="Finite Element Embedded Language and Library in C++"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/feelpp"
license=('LGPL')
depends=('cln' 'mumps' 'slepc' 'gmsh' 'fftw' 'ann' 'glpk' 'gsl' 'python')
@@ -17,9 +14,6 @@ prepare() {
cd ${pkgname}-${pkgver}
git submodule init
git submodule update -f --init
-
- # https://github.com/feelpp/feelpp/pull/1415
- git cherry-pick cad7be165e2c4e377a4acfcf89abfb5365b43601 8b29331f5b2a4c6f47631b788829d5529eaf2d17
}
build() {
@@ -37,14 +31,15 @@ build() {
-DFEELPP_ENABLE_PYFEELPP_LIBFEELPP=OFF \
-DFEELPP_ENABLE_DOCUMENTATION=OFF \
-DFEELPP_ENABLE_GMSH=ON \
- -DFEELPP_ENABLE_PETSC=OFF \
- -DFEELPP_ENABLE_SLEPC=OFF \
+ -DFEELPP_ENABLE_PETSC=ON \
+ -DFEELPP_ENABLE_SLEPC=ON \
-DFEELPP_ENABLE_ANN=ON \
-DFEELPP_ENABLE_FFTW=ON \
-DFEELPP_ENABLE_GSL=ON \
-DFEELPP_ENABLE_SYSTEM_EIGEN3=ON \
-DCMAKE_C_COMPILER=/usr/bin/clang \
-DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DBUILD_TESTING=OFF \
..
make
}