summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-07-06 15:35:32 +0200
committerbionade242020-07-06 15:35:32 +0200
commit66ce4e37ed27a1a585d2f1bb7b04e5f34795aff2 (patch)
treed699f84ba09b057497c1470a267fc80c90ad06f9
parent3c1b75afae580d5a4d97b6f828ae9adfb4b4a24f (diff)
downloadaur-66ce4e37ed27a1a585d2f1bb7b04e5f34795aff2.tar.gz
Set python version to 3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cacd2e15dca6..e9ebf28b1cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-easy-markers
pkgdesc = ROS - Python library to assist in publishing markers easily.
pkgver = 0.2.6
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ros.org/easy_markers
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 3df378d5f648..e4e476739531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/easy_markers'
pkgname='ros-melodic-easy-markers'
pkgver='0.2.6'
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-melodic-tf
@@ -48,14 +48,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}