summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortelans2019-08-10 18:32:24 +1200
committertelans2019-08-10 18:32:24 +1200
commit66df1b24c4cd18f2462e59ce15312b0657cb5f06 (patch)
treeeb7a4da32d155020f0fe3c1b6610507045fcd53b
parent179205d3f39b561b69af0cd04495007770db09a8 (diff)
downloadaur-66df1b24c4cd18f2462e59ce15312b0657cb5f06.tar.gz
fix unloading
-rw-r--r--PKGBUILD5
-rwxr-xr-xfuzion-load4
-rwxr-xr-xfuzion-unload19
3 files changed, 0 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 767267f055f1..388b5b52893c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,11 +44,6 @@ package() {
install -Dm755 fuzion-unload "$pkgdir/usr/bin/fuzion-unload"
cd "$_pkgname"
install -Dm755 "build_id" "$pkgdir/usr/share/Fuzion/build_id"
- if [ -f build_id_old ]; then
- install -Dm755 "build_id_old" "$pkgdir/usr/share/Fuzion/build_id_old"
- else
- touch "$pkgdir/usr/share/Fuzion/build_id_old"
- fi
_buildname="$(cat build_id)"
install -Dm755 "$_buildname" "$pkgdir/usr/lib/$_buildname"
}
diff --git a/fuzion-load b/fuzion-load
index db5888fe3f56..a0d4809f3443 100755
--- a/fuzion-load
+++ b/fuzion-load
@@ -20,10 +20,6 @@ if [ -z "$csgo_pid" ]; then
exit 1
fi
-if [ ! -d ".git" ]; then
- echo "We have detected that you have downloaded Fuzion-master.zip from GitHub.com. This is the WRONG way to download! Please download Fuzion by cloning the Git repository: 'git clone --recursive https://github.com/LWSS/Fuzion.git'"
-fi
-
# pBypass for crash dumps being sent
# You may also want to consider using -nobreakpad in your launch options.
sudo rm -rf /tmp/dumps # Remove if it exists
diff --git a/fuzion-unload b/fuzion-unload
index ddbc7eada7a8..59015f217fb4 100755
--- a/fuzion-unload
+++ b/fuzion-unload
@@ -25,23 +25,4 @@ if [ -f /usr/share/Fuzion/build_id ]; then
fi
fi
-# "build_id_old" is used for unloading in case you rebuild while injected.
-if [ -f /usr/share/Fuzion/build_id_old ]; then
- if grep -q "$filename_old" /proc/"$csgo_pid"/maps; then
- echo "unloading old file - $filename_old"
- sudo gdb -n -q -batch-silent \
- -ex "set logging on" \
- -ex "set logging file /dev/null" \
- -ex "set logging redirect on" \
- -ex "attach $csgo_pid" \
- -ex "set \$dlopen = (void*(*)(char*, int)) dlopen" \
- -ex "set \$dlclose = (int(*)(void*)) dlclose" \
- -ex "set \$library = \$dlopen(\"/usr/lib/$filename_old\", 6)" \
- -ex "call \$dlclose(\$library)" \
- -ex "call \$dlclose(\$library)" \
- -ex "detach" \
- -ex "quit"
- fi
-fi
-
echo "Done. See CS:GO Console."