summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-08-10 16:24:40 -0400
committerSolomon Choina2020-08-10 16:24:40 -0400
commit66f35fff215dda1e482c2dbaa8c212719d07a143 (patch)
tree9226b75b775f0523838f7fd951c897e092842d3d
parent195067d8f2565eda641c30d5e76f8c3b096c111b (diff)
downloadaur-66f35fff215dda1e482c2dbaa8c212719d07a143.tar.gz
better pkgver and using wingpanel stable
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 973e9cd41386..5cbf181b1535 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Jul 20 19:07:26 UTC 2018
pkgbase = wingpanel-indicator-notifications-git
pkgdesc = Notifications indicator for Wingpanel
- pkgver = r307.2532c8a
+ pkgver = 2.1.4.r15.gf06603e
pkgrel = 1
url = https://github.com/elementary/wingpanel-indicator-notifications
arch = x86_64
@@ -12,7 +10,7 @@ pkgbase = wingpanel-indicator-notifications-git
makedepends = granite-git
makedepends = meson
makedepends = vala
- makedepends = wingpanel-git
+ makedepends = wingpanel
depends = glib2
depends = glibc
depends = gtk3
diff --git a/PKGBUILD b/PKGBUILD
index 3a7b4bb79146..9a4a6d9a17a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-indicator-notifications-git
-pkgver=r307.2532c8a
+pkgver=2.1.4.r15.gf06603e
pkgrel=1
pkgdesc='Notifications indicator for Wingpanel'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('glib2' 'glibc' 'gtk3' 'libgee' 'libwnck3'
'libgranite.so' 'libwingpanel-2.0.so')
-makedepends=('git' 'granite-git' 'meson' 'vala' 'wingpanel-git')
+makedepends=('git' 'granite-git' 'meson' 'vala' 'wingpanel')
provides=('wingpanel-indicator-notifications')
conflicts=('wingpanel-indicator-notifications')
source=('git+https://github.com/elementary/wingpanel-indicator-notifications.git')
@@ -19,27 +19,17 @@ sha256sums=('SKIP')
pkgver() {
cd wingpanel-indicator-notifications
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd build
-
- arch-meson ../wingpanel-indicator-notifications
- ninja
+ arch-meson wingpanel-indicator-notifications build
+ ninja -C build
}
package() {
- cd build
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: