summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlpxl2020-10-17 18:23:21 -0300
committerlpxl2020-10-17 18:23:21 -0300
commit66f82850e58509d966af3242e0b7a2df8e5c98fc (patch)
treecbf76243067d4289f67d748b2c0946034bf05a23
downloadaur-66f82850e58509d966af3242e0b7a2df8e5c98fc.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD40
-rw-r--r--io.github.RodZill4.Material-Maker.appdata.xml31
-rw-r--r--io.github.RodZill4.Material-Maker.desktop11
-rw-r--r--material-maker.pngbin0 -> 7759 bytes
6 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45a5d32999da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = material-maker-bin
+ pkgdesc = A tool based on Godot Engine that can be used to create textures procedurally
+ pkgver = 0.93
+ pkgrel = 1
+ url = https://rodzilla.itch.io/material-maker
+ arch = x86_64
+ license = MIT
+ depends = libpulse
+ depends = alsa-lib
+ depends = libxrandr
+ depends = libglvnd
+ depends = libxcursor
+ depends = libxinerama
+ depends = hicolor-icon-theme
+ provides = material-maker
+ conflicts = material-maker
+ conflicts = material-maker-git
+ options = !strip
+ source = https://github.com/RodZill4/material-maker/releases/download/0.93/material_maker_0_93_linux.tar.gz
+ source = io.github.RodZill4.Material-Maker.appdata.xml
+ source = io.github.RodZill4.Material-Maker.desktop
+ source = material-maker.png
+ source = LICENSE
+ sha256sums = b85f2c2b577e899d741c50d1047bb3870fd4a784f3927112264eba737890b28f
+ sha256sums = 4a27286e448b35c2e7e840c267ac2402f53956ff9fcb5c5f8285797753c32e38
+ sha256sums = d8c96863144183d9f256229232c0cfe18b10518abdb2bba3477781a8d96f0133
+ sha256sums = b6217901109513d5856369b1d9fd8a1981b584ab8d3091fa9c37691782495222
+ sha256sums = ddbacfaf9c588c476c73073e27f69d8137fe41cec7e9081ad0f6fefaa92541b3
+
+pkgname = material-maker-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c220a86feba9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+# MIT License
+
+Copyright (c) 2018-2020 Rodolphe Suescun and contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..168562ae3c4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
+pkgname=material-maker-bin
+_pkgname=material_maker
+pkgver=0.93
+_pkgver=${pkgver//./_}
+pkgrel=1
+pkgdesc="A tool based on Godot Engine that can be used to create textures procedurally"
+arch=('x86_64')
+url="https://rodzilla.itch.io/material-maker"
+license=('MIT')
+depends=('libpulse' 'alsa-lib' 'libxrandr' 'libglvnd' 'libxcursor' 'libxinerama' 'hicolor-icon-theme')
+options=(!strip)
+provides=('material-maker')
+conflicts=('material-maker' 'material-maker-git')
+source=(https://github.com/RodZill4/material-maker/releases/download/${pkgver}/${_pkgname}_${_pkgver}_linux.tar.gz
+ io.github.RodZill4.Material-Maker.appdata.xml
+ io.github.RodZill4.Material-Maker.desktop
+ material-maker.png
+ LICENSE)
+sha256sums=('b85f2c2b577e899d741c50d1047bb3870fd4a784f3927112264eba737890b28f'
+ '4a27286e448b35c2e7e840c267ac2402f53956ff9fcb5c5f8285797753c32e38'
+ 'd8c96863144183d9f256229232c0cfe18b10518abdb2bba3477781a8d96f0133'
+ 'b6217901109513d5856369b1d9fd8a1981b584ab8d3091fa9c37691782495222'
+ 'ddbacfaf9c588c476c73073e27f69d8137fe41cec7e9081ad0f6fefaa92541b3')
+
+package() {
+ install -d "$pkgdir/opt/$pkgname"
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/metainfo"
+ install -d "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/share/icons/hicolor/64x64/apps"
+
+ cp -Trf "$srcdir/${_pkgname}_${_pkgver}_linux" "$pkgdir/opt/$pkgname"
+ install -Dm644 "$srcdir/io.github.RodZill4.Material-Maker.desktop" "$pkgdir/usr/share/applications"
+ install -Dm644 "$srcdir/io.github.RodZill4.Material-Maker.appdata.xml" "$pkgdir/usr/share/metainfo"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/material-maker.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps"
+
+ ln -s /opt/${pkgname}/${_pkgname}.${CARCH} "$pkgdir/usr/bin/material-maker"
+}
diff --git a/io.github.RodZill4.Material-Maker.appdata.xml b/io.github.RodZill4.Material-Maker.appdata.xml
new file mode 100644
index 000000000000..67a605aaa75d
--- /dev/null
+++ b/io.github.RodZill4.Material-Maker.appdata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright (c) 2018-2020 Rodolphe Suescun and contributors -->
+<component type="desktop">
+ <id>io.github.RodZill4.Material-Maker.desktop</id>
+ <name>Material Maker</name>
+ <summary>Procedural texture generation tool</summary>
+ <description>
+ <p>
+ Material Maker is a tool that can be used to create textures procedurally.
+ </p>
+ </description>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>MIT</project_license>
+ <developer_name>Rodolphe Suescun and contributors</developer_name>
+ <url type="homepage">https://github.com/RodZill4/material-maker</url>
+ <url type="help">https://rodzill4.github.io/material-maker/doc/</url>
+ <url type="bugtracker">https://github.com/RodZill4/material-maker/issues</url>
+ <screenshots>
+ <screenshot type="default">
+ <image type="source" width="1282" height="752">https://raw.githubusercontent.com/RodZill4/material-maker/master/material_maker/doc/images/screenshot.png</image>
+ <caption>Editing a procedurally generated texture</caption>
+ </screenshot>
+ </screenshots>
+ <content_rating type="oars-1.1"/>
+ <releases>
+ <release version="0.93" date="2020-10-11"/>
+ <release version="0.92" date="2020-06-27"/>
+ <release version="0.9" date="2020-03-15"/>
+ </releases>
+ <update_contact>hugo.locurcio@hugo.pro</update_contact>
+</component>
diff --git a/io.github.RodZill4.Material-Maker.desktop b/io.github.RodZill4.Material-Maker.desktop
new file mode 100644
index 000000000000..a7702f622bc6
--- /dev/null
+++ b/io.github.RodZill4.Material-Maker.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Material Maker
+GenericName=Procedural texture generation tool
+GenericName[fr]=Outil de génération de textures procédurales
+Comment=Generate textures procedurally for use in PBR engines
+Comment[fr]=Générez des textures procéduralement pour des moteurs de rendu PBR
+Exec=material-maker
+Icon=material-maker
+Terminal=false
+Type=Application
+Categories=Graphics;3DGraphics;
diff --git a/material-maker.png b/material-maker.png
new file mode 100644
index 000000000000..59587213e8e7
--- /dev/null
+++ b/material-maker.png
Binary files differ