summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Seo2023-03-23 12:12:46 +0900
committerStephen Seo2023-03-23 12:17:19 +0900
commit66f85b7650ef3166d5cd80e8ae61e3dfe368bad8 (patch)
tree55dd62d4de803376dcdb2ed5dcce0258c4d32ec7
parentb39e4b373c1f7198db1dd72f2d5f4bb92367a9c2 (diff)
downloadaur-66f85b7650ef3166d5cd80e8ae61e3dfe368bad8.tar.gz
Update to new raylib version 4.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--raylib_glfw.patch12
3 files changed, 5 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3944c5077a7c..c19a6613b2db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-raylib
pkgdesc = Simple and easy to use game programming library (mingw-w64)
- pkgver = 4.2.0
+ pkgver = 4.5.0
pkgrel = 1
url = https://www.raylib.com
arch = any
@@ -11,9 +11,7 @@ pkgbase = mingw-w64-raylib
options = !strip
options = !buildflags
options = staticlibs
- source = raylib_4.2.0.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/4.2.0.tar.gz
- source = raylib_glfw.patch
- md5sums = 8b63a4d4a1e4356fc332fa16eb85d87e
- md5sums = a44c1130eac923910f3047696c9a7363
+ source = raylib_4.5.0.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/4.5.0.tar.gz
+ md5sums = feb608a91e27f71f9b33f0073177b1ee
pkgname = mingw-w64-raylib
diff --git a/PKGBUILD b/PKGBUILD
index 946a560858b5..c122f6bc82b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stephen Seo <seo.disparate@gmail.com>
pkgname=mingw-w64-raylib
-pkgver=4.2.0
+pkgver=4.5.0
pkgrel=1
pkgdesc="Simple and easy to use game programming library (mingw-w64)"
arch=(any)
@@ -17,19 +17,16 @@ options=(!strip !buildflags staticlibs)
install=
source=(
"raylib_${pkgver}.tar.gz::https://github.com/raysan5/raylib/archive/refs/tags/${pkgver}.tar.gz"
- 'raylib_glfw.patch'
)
noextract=()
md5sums=(
- 8b63a4d4a1e4356fc332fa16eb85d87e
- a44c1130eac923910f3047696c9a7363
+ feb608a91e27f71f9b33f0073177b1ee
)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "$srcdir/raylib-${pkgver}"
- patch -p1 < "$srcdir/raylib_glfw.patch"
}
build() {
diff --git a/raylib_glfw.patch b/raylib_glfw.patch
deleted file mode 100644
index 8f3e28b7ae1b..000000000000
--- a/raylib_glfw.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fixes issues with name conflicts building with external glfw
---- a/src/rcore.c
-+++ b/src/rcore.c
-@@ -214,7 +214,7 @@
-
- // Support retrieving native window handlers
- #if defined(_WIN32)
-- #define GLFW_EXPOSE_NATIVE_WIN32
-+// #define GLFW_EXPOSE_NATIVE_WIN32
- #include "GLFW/glfw3native.h" // WARNING: It requires customization to avoid windows.h inclusion!
-
- #if defined(SUPPORT_WINMM_HIGHRES_TIMER) && !defined(SUPPORT_BUSY_WAIT_LOOP)