summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2016-12-12 13:43:04 +0100
committerEinhard Leichtfuß2016-12-12 13:44:37 +0100
commit671399b74ff5b736810dff4e001e72d83d4e237d (patch)
treeceb1044acd271184051f78633133fa7a17c482bf
parent6cf84927db7120b57eea6d143abd88a12e059b92 (diff)
downloadaur-671399b74ff5b736810dff4e001e72d83d4e237d.tar.gz
Update to version 3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD53
2 files changed, 41 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f5c5b138ad4..e8bfce2a0a43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dict-wn
pkgdesc = WordNet for dictd et al.
- pkgver = 3.0
- pkgrel = 5
+ pkgver = 3.1
+ pkgrel = 1
url = https://wordnet.princeton.edu/
install = dict-wn.install
arch = any
@@ -14,8 +14,10 @@ pkgbase = dict-wn
optdepends = dictd: dict client and server
provides = dictd-wn
conflicts = dictd-wn
+ source = http://wordnetcode.princeton.edu/wn3.1.dict.tar.gz
source = http://ftp.de.debian.org/debian/pool/main/w/wordnet/wordnet_3.0.orig.tar.gz
- md5sums = a91cee4bab52c750dc25e3b1d296a091
+ sha512sums = 16dca17a87026d8a0b7b4758219cd21a869c3ef3da23ce7875924546f2eacac4c2f376cb271b798b2c458fe8c078fb43d681356e3d9beef40f4bd88d3579394f
+ sha512sums = f153ea6be57ef57b18e4f0857e2ce0493ee75171f60df4b3aa669f4279c1b2ad91641da166b450d95a89166d50d6dc0d9f199710fa2f1ab934882028760d6917
pkgname = dict-wn
diff --git a/PKGBUILD b/PKGBUILD
index ff15a0fd054b..8c9457d328fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Enrico Morelli <morelli@cerm.unifi.it>
# Contributor: Andrew Engelbrecht <sudoman@ninthfloor.org>
pkgname=dict-wn
-pkgver=3.0
-pkgrel=5
+pkgver=3.1
+_debver=3.0
+pkgrel=1
pkgdesc="WordNet for dictd et al."
arch=('any')
url="https://wordnet.princeton.edu/"
@@ -12,32 +13,50 @@ optdepends=('dictd: dict client and server')
makedepends=('dictd' 'tk' 'python2' 'ghostscript')
provides=('dictd-wn')
conflicts=('dictd-wn')
-install=$pkgname.install
-# the tarball from debian is required, since it contains wordnet_structures.py
-source=("http://ftp.de.debian.org/debian/pool/main/w/wordnet/wordnet_$pkgver.orig.tar.gz")
-md5sums=('a91cee4bab52c750dc25e3b1d296a091');
+install="${pkgname}.install"
-build() {
- cd WordNet-$pkgver
- ./configure
+# The tarball from debian is required for wordnet_structures.py .
+source=("http://wordnetcode.princeton.edu/wn${pkgver}.dict.tar.gz"
+ "http://ftp.de.debian.org/debian/pool/main/w/wordnet/wordnet_${_debver}.orig.tar.gz")
+sha512sums=('16dca17a87026d8a0b7b4758219cd21a869c3ef3da23ce7875924546f2eacac4c2f376cb271b798b2c458fe8c078fb43d681356e3d9beef40f4bd88d3579394f'
+ 'f153ea6be57ef57b18e4f0857e2ce0493ee75171f60df4b3aa669f4279c1b2ad91641da166b450d95a89166d50d6dc0d9f199710fa2f1ab934882028760d6917')
+
+prepare()
+{
+ cp -rf dict/* "WordNet-${_debver}/dict/"
+
+ cd "WordNet-${_debver}"
+
+ # Apparently, the naming conventions changed.
+ # Use the old ones.
+ mv -f "dict/dbfiles/verb.Framestext" "dict/frames.vrb"
- # we need to use python2, pass the name, and the url of the new WN version
- sed -i 's/python wordnet_structures.py/python2 wordnet_structures.py --wn_url="http:\/\/wordnet\.princeton.edu" --db_desc_short=" WordNet \(r\) 3\.0 \(2006\)"/g' contrib/wordnet_structures/Makefile
+ # Pretend old version.
+ mv -f "dict/log.grind."{"${pkgver}","${_debver}"}
- # Tcl_Interp structure does by default not contain result
+ # Use python2, pass the url and the name with the new version.
+ sed -i 's/python wordnet_structures.py/python2 wordnet_structures.py --wn_url="http:\/\/wordnet\.princeton.edu" --db_desc_short=" WordNet \(r\) '"${pkgver}"' \(2011\)"/g' contrib/wordnet_structures/Makefile.in
+
+ # Tcl_Interp structure does by default not contain result.
sed -i 's/^#include <tcl.h>$/#define USE_INTERP_RESULT\n#include <tcl.h>/' src/stubs.c
+}
+build() {
+ cd "WordNet-${_debver}"
+ ./configure
make
}
package() {
- cd WordNet-$pkgver
+ cd "WordNet-${_debver}"
mkdir -p "$pkgdir/usr/share/dictd/"
cp contrib/wordnet_structures/wn.{dict.dz,index} "$pkgdir/usr/share/dictd/"
- install -m 0755 -d "$pkgdir/usr/share/doc/$pkgname"
- install -m 0644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS COPYING NEWS README
+ install -m 0755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # Note, that the documentation will be for the old version.
+ install -m 0644 -t "${pkgdir}/usr/share/doc/${pkgname}/" AUTHORS COPYING NEWS README
- mkdir -p "$pkgdir/usr/share/licenses/dict-wn"
- ln -s /usr/share/doc/dict-wn/COPYING "$pkgdir/usr/share/licenses/dict-wn"
+ mkdir -p "{$pkgdir}/usr/share/licenses/dict-wn"
+ ln -s /usr/share/doc/dict-wn/COPYING "${pkgdir}/usr/share/licenses/dict-wn"
}