summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2022-01-18 10:44:36 +1100
committerLuis Aranguren2022-01-18 10:44:36 +1100
commit671f6123ae91706ae904e813357f5f645e5e8510 (patch)
treeea0522d74eec2a0de5914d4c02058386bdde8692
parent78fb748b873fa59a7e317df609b6c52845f51612 (diff)
downloadaur-671f6123ae91706ae904e813357f5f645e5e8510.tar.gz
[1.2.0-3] removed python2-pylru
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 7 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b40543e66b2..e121d00509ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
pkgbase = python-pylru
pkgdesc = A least recently used (LRU) cache implementation
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jlhutch/pylru
arch = any
license = GPL2
makedepends = python-setuptools
- makedepends = python2-setuptools
options = !emptydirs
source = pylru-1.2.0.tar.gz::https://github.com/jlhutch/pylru/archive/v1.2.0.tar.gz
sha256sums = c4dcf175f6317539199434db13ffea0f642a52fac1e547e2e5f0866686fc9292
pkgname = python-pylru
depends = python
-
-pkgname = python2-pylru
- depends = python2
-
diff --git a/PKGBUILD b/PKGBUILD
index 689780b99091..97ae5d738039 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
-# Maintainer: Niklas <dev@n1klas.net>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Niklas <dev@n1klas.net>
pkgbase=python-pylru
-pkgname=('python-pylru' 'python2-pylru')
+pkgname=('python-pylru')
_name=pylru
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="A least recently used (LRU) cache implementation"
arch=('any')
url="https://github.com/jlhutch/pylru"
license=('GPL2')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
options=(!emptydirs)
source=("${_name}-${pkgver}.tar.gz::https://github.com/jlhutch/pylru/archive/v${pkgver}.tar.gz")
sha256sums=('c4dcf175f6317539199434db13ffea0f642a52fac1e547e2e5f0866686fc9292')
@@ -22,9 +23,6 @@ prepare() {
build() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/${_name}-${pkgver}-python2"
- python2 setup.py build
}
package_python-pylru() {
@@ -33,10 +31,3 @@ package_python-pylru() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --skip-build --optimize=1
}
-
-package_python2-pylru() {
- depends=('python2')
-
- cd "${srcdir}/${_name}-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}" --skip-build --optimize=1
-}