summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGereon Schomber2015-06-30 23:55:15 +0200
committerGereon Schomber2015-06-30 23:55:15 +0200
commit677016b989301bff8ea3fbd218929aae082a118f (patch)
tree874bfbc9db7aa5084e1724435c13228888517998
downloadaur-677016b989301bff8ea3fbd218929aae082a118f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..877df5dd9577
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ortp-git
+ pkgdesc = oRTP is a LGPL licensed C library implementing the RTP protocol (rfc3550)
+ pkgver = 0.22.0.r276.gfbe5a32
+ pkgrel = 1
+ url = http://www.linphone.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL2
+ depends = openssl
+ depends = libsrtp
+ provides = ortp
+ conflicts = ortp
+ options = !libtool
+ source = git://git.linphone.org/ortp.git
+ sha256sums = SKIP
+
+pkgname = ortp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..319c347c18b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=ortp-git
+_basename="ortp"
+pkgver=0.22.0.r276.gfbe5a32
+pkgrel=1
+pkgdesc="oRTP is a LGPL licensed C library implementing the RTP protocol (rfc3550)"
+arch=(i686 x86_64)
+url="http://www.linphone.org/"
+license=('LGPL2')
+options=(!libtool)
+depends=('openssl' 'libsrtp')
+source=("git://git.linphone.org/${_basename}.git")
+sha256sums=('SKIP')
+
+provides=("${_basename}")
+conflicts=("${_basename}")
+
+prepare() {
+ cd "$_basename"
+ ./autogen.sh
+}
+
+build() {
+ cd "$_basename"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_basename"
+ make DESTDIR=$pkgdir install
+}
+
+pkgver() {
+ cd "$_basename"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}