summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGenerator2019-03-06 22:06:09 +0000
committerGenerator2019-03-06 22:06:09 +0000
commit67884a861674b329b36d3b5a1cf457d07df79fbe (patch)
treeeab9826f3fe18de9e3a455b54bb2d06d1e5c0515
parent31810955c512f16f6758f1e99965208b51649c67 (diff)
downloadaur-67884a861674b329b36d3b5a1cf457d07df79fbe.tar.gz
removed generate_playlist.sh
add new dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 574963f05348..22ceed3e682e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sddm-theme-aerial-git
pkgdesc = SDDM theme with Apple TV Aerial videos
- pkgver = 0.1.r24.g90d9941
+ pkgver = 0.1.r39.gd583097
pkgrel = 1
url = https://github.com/3ximus/aerial-sddm-theme
install = sddm-theme-aerial.install
@@ -10,9 +10,10 @@ pkgbase = sddm-theme-aerial-git
makedepends = python2
depends = sddm
depends = gst-libav
- depends = gst-plugins-good
depends = phonon-qt5-gstreamer
- depends = qt5-multimedia
+ depends = gst-plugins-good
+ depends = qt5-quickcontrols
+ depends = qt5-graphicaleffects
backup = usr/share/sddm/themes/aerial/theme.conf.user
source = git+https://github.com/3ximus/aerial-sddm-theme.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 76ea8e89c992..96fff9b33060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_repo=aerial-sddm-theme
_pkgname=sddm-theme-aerial
pkgname=$_pkgname-git
-pkgver=0.1.r24.g90d9941
+pkgver=0.1.r39.gd583097
pkgrel=1
pkgdesc="SDDM theme with Apple TV Aerial videos"
arch=('any')
url="https://github.com/3ximus/aerial-sddm-theme"
license=('GPL')
-depends=('sddm' 'gst-libav' 'gst-plugins-good' 'phonon-qt5-gstreamer' 'qt5-multimedia')
+depends=('sddm' 'gst-libav' 'phonon-qt5-gstreamer' 'gst-plugins-good' 'qt5-quickcontrols' 'qt5-graphicaleffects')
makedepends=('git' 'python2')
install="$_pkgname.install"
backup=('usr/share/sddm/themes/aerial/theme.conf.user')
@@ -24,11 +24,13 @@ pkgver() {
}
build() {
cd ${srcdir}/$_repo
- sh generate_playlist.sh
if [ -d screens ]; then
rm -rf screens
+ rm README.md
fi
}
package() {
- install -Dm644 -t "$pkgdir/usr/share/sddm/themes/aerial/" ${srcdir}/$_repo/*
+ mkdir -p "$pkgdir/usr/share/sddm/themes/aerial/"
+ mv ${srcdir}/$_repo/* "$pkgdir/usr/share/sddm/themes/aerial/"
+ chmod 644 "$pkgdir/usr/share/sddm/themes/aerial/"
}