summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-13 18:41:42 -0600
committerBrian Bidulock2015-07-13 18:41:42 -0600
commit67c2d9ab44b1ef436dba025ed927b22b099e7ae5 (patch)
tree5fed734542715a16e2bdf60ab9d9fe97fe1c11b4
downloadaur-67c2d9ab44b1ef436dba025ed927b22b099e7ae5.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7aa0147fa03a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xdwm
+ pkgdesc = An extended dynamic window manager for X (dwm fork)
+ pkgver = 6.1p7
+ pkgrel = 1
+ url = http://github.com/aperezdc/xdwm
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libx11
+ depends = libxinerama
+ depends = xorg-xrdb
+ optdepends = pulseaudio: launch pulseaudio at session startup
+ optdepends = gnome-keyring: launch GNOME keyring at session startup
+ optdepends = consolekit: register sessions with ConsoleKit
+ source = https://github.com/downloads/aperezdc/xdwm/xdwm-6.1p7.tar.gz
+ md5sums = f7aeee78df89fb646fccd385f9cfca74
+
+pkgname = xdwm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2db86b47a66e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname='xdwm'
+pkgver='6.1p7'
+pkgrel=1
+pkgdesc='An extended dynamic window manager for X (dwm fork)'
+url='http://github.com/aperezdc/xdwm'
+license=('MIT')
+source=("https://github.com/downloads/aperezdc/$pkgname/$pkgname-$pkgver.tar.gz")
+arch=('i686' 'x86_64')
+md5sums=('f7aeee78df89fb646fccd385f9cfca74')
+depends=('libx11' 'libxinerama' 'xorg-xrdb')
+optdepends=(
+ 'pulseaudio: launch pulseaudio at session startup'
+ 'gnome-keyring: launch GNOME keyring at session startup'
+ 'consolekit: register sessions with ConsoleKit'
+)
+
+build () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr
+ make PREFIX=/usr -C session
+}
+
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}/" install
+ make PREFIX=/usr DESTDIR="${pkgdir}/" -C session install
+}