summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim van Leuverden2022-10-14 14:48:25 +0200
committerTim van Leuverden2022-10-14 14:48:25 +0200
commit67c4381092c4276f5bd10d9e4482c469c9440e14 (patch)
tree96e7c9a06501bff42a72dfc7eb639adb73de4656
parent775fa24d2bf9debb20d2a5f1388fecd455bade94 (diff)
downloadaur-67c4381092c4276f5bd10d9e4482c469c9440e14.tar.gz
Upstream release: v0.8.5
Signed-off-by: Mubashshir <ahmubashshir@gmail.com> Reviewed-by: Tim van Leuverden <TvanLeuverden@Gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 592e938b80ec..22f564c23fe2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trackma
pkgdesc = A lightweight and simple program for updating and using lists on several media tracking websites.
- pkgver = 0.8.4
- pkgrel = 2
+ pkgver = 0.8.5
+ pkgrel = 1
url = http://z411.github.io/trackma/
arch = any
license = GPL3
@@ -15,17 +15,18 @@ pkgbase = trackma
optdepends = python-urwid: ncurses frontend
optdepends = python-pillow: thumbnail images for GUI frontends
optdepends = python-pyinotify: instant media recognition tracker
- optdepends = dbus-python: MPRIS media recognition tracker
+ optdepends = python-pydbus: MPRIS media recognition tracker
optdepends = lsof: polling tracker/pyinotify alternative
conflicts = trackma-git
- source = trackma-0.8.4::git+https://github.com/z411/trackma.git#tag=v0.8.4
+ source = trackma-0.8.5::git+https://github.com/z411/trackma.git#tag=v0.8.5
+ source = anime-relations::git+https://github.com/erengy/anime-relations.git
source = trackma-curses.desktop
source = trackma-gtk.desktop
source = trackma-qt.desktop
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 80be9ffc3eb66456004a438a3da8950ed8382faa00a3fe61c5ef3980090c4dce
sha256sums = a737f0fd38af4c472dfbca8503f57763bbec7c91568221298db317421a6c5604
sha256sums = 988f4c4422577f0657e9ff8a9695ef44796ee6a9c43e07ee7a81369f25c2761f
pkgname = trackma
-
diff --git a/.gitignore b/.gitignore
index a452b3062516..0a9e503958f4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
*/*
*.tar.*
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 228a37b407d5..a564e5338655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
-# Maintainer: Tim van Leuverden <timmy1e at protonmail dot ch>
+# Maintainer: Tim van Leuverden <tvanleuverden at gmail dot com>
+# Contributor: Joost Bremmer
+# Contributor: Mubashshir <ahmubashshir at gmail dot com>
pkgname=trackma
-pkgver=0.8.4
-pkgrel=2
+pkgver=0.8.5
+pkgrel=1
pkgdesc="A lightweight and simple program for updating and using lists on several media tracking websites."
url="http://z411.github.io/trackma/"
arch=('any')
@@ -20,22 +22,27 @@ optdepends=('python-gobject: GTK frontend'
'python-urwid: ncurses frontend'
'python-pillow: thumbnail images for GUI frontends'
'python-pyinotify: instant media recognition tracker'
- 'dbus-python: MPRIS media recognition tracker'
+ 'python-pydbus: MPRIS media recognition tracker'
'lsof: polling tracker/pyinotify alternative')
source=("${pkgname}-${pkgver}::git+https://github.com/z411/${pkgname}.git#tag=v${pkgver}"
+ "anime-relations::git+https://github.com/erengy/anime-relations.git"
"${pkgname}-curses.desktop"
"${pkgname}-gtk.desktop"
"${pkgname}-qt.desktop")
sha256sums=('SKIP'
+ 'SKIP'
'80be9ffc3eb66456004a438a3da8950ed8382faa00a3fe61c5ef3980090c4dce'
'a737f0fd38af4c472dfbca8503f57763bbec7c91568221298db317421a6c5604'
'988f4c4422577f0657e9ff8a9695ef44796ee6a9c43e07ee7a81369f25c2761f')
prepare() {
cd ${pkgname}-${pkgver}
- git submodule update --init --recursive
+
+ git submodule init
+ git config submodule."trackma/data/anime-relations".url $srcdir/anime-relations
+ git submodule update
}
package() {
@@ -55,4 +62,4 @@ package() {
"${pkgdir}/usr/share/applications/${pkgname}-qt.desktop"
}
-# vim: sw=2 ts=2 tw=80 et: \ No newline at end of file
+# vim: sw=2 ts=2 tw=80 et: