summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan2016-08-29 11:52:52 -0400
committerJuan2016-08-29 11:52:52 -0400
commit67e50808b753633a97d17a845539840629675ee4 (patch)
tree756b5605ea15baaa2e0d0c01dfcff0883dcc7fd5
downloadaur-67e50808b753633a97d17a845539840629675ee4.tar.gz
upload to bitbucket
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
-rwxr-xr-xnatron.desktop12
-rw-r--r--natronIcon256_linux.pngbin0 -> 12235 bytes
-rw-r--r--natronProjectIcon_linux.pngbin0 -> 9110 bytes
-rw-r--r--x-natron.xml9
6 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3528b5f37cfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = natron-portable
+ pkgdesc = Video compositing software similar to Nuke and Adobe After Effects, portable snapshot
+ pkgver = 2.1.2
+ pkgrel = 2
+ url = http://natron.fr/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ffmpeg
+ depends = p7zip
+ optdepends = blender: for 3d opencolor-io support
+ conflicts = natron
+ options = !strip
+ source = natron.desktop
+ source = x-natron.xml
+ source = natronIcon256_linux.png
+ source = natronProjectIcon_linux.png
+ md5sums = 5c65b106c295abe0b5346eff18a06767
+ md5sums = ca5186feb5a7f336517c015f72d0f8c8
+ md5sums = 60eb9f97a0ddeab5acda48d15894559a
+ md5sums = 475e14142c51d8b545f7cbc4b5426ce2
+ source_i686 = https://bitbucket.org/juanperez89/natron/downloads/Natron-2.1.1-Linux-x86_32bit-portable.tar.xz
+ md5sums_i686 = df9b7998c373214a0d5449866c6d4412
+ source_x86_64 = https://bitbucket.org/juanperez89/natron/downloads/Natron-2.1.2-Linux-x86_64bit-portable.tar.xz
+ md5sums_x86_64 = 781c3812b3a2194bca5ea8c864134dbb
+
+pkgname = natron-portable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b91cfdeccb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Thomas Scheiblhuber <thomas@scheiblhuber.de>
+# Contributor: Joonas Henriksson
+# Contributor: Rutger Broekhoff
+# Contributor: gatitofeliz at protonmail dot com
+pkgname=natron-portable
+pkgver=2.1.2
+pkgrel=2
+
+arch=('i686' 'x86_64')
+pkgdesc='Video compositing software similar to Nuke and Adobe After Effects, portable snapshot'
+url='http://natron.fr/'
+license=('GPL')
+depends=('ffmpeg' 'p7zip')
+optdepends=('blender: for 3d opencolor-io support')
+conflicts=('natron')
+
+options=('!strip')
+
+source=("natron.desktop" "x-natron.xml" "natronIcon256_linux.png" "natronProjectIcon_linux.png")
+source_i686=("https://bitbucket.org/juanperez89/natron/downloads/Natron-2.1.1-Linux-x86_32bit-portable.tar.xz")
+source_x86_64=("https://bitbucket.org/juanperez89/natron/downloads/Natron-2.1.2-Linux-x86_64bit-portable.tar.xz")
+
+md5sums=('5c65b106c295abe0b5346eff18a06767' 'ca5186feb5a7f336517c015f72d0f8c8' '60eb9f97a0ddeab5acda48d15894559a' '475e14142c51d8b545f7cbc4b5426ce2')
+md5sums_i686=('df9b7998c373214a0d5449866c6d4412')
+md5sums_x86_64=('781c3812b3a2194bca5ea8c864134dbb')
+
+package() {
+ if [ "$CARCH" = "x86_64" ]; then
+ _source_arch="x86_64bit"
+ else
+ _source_arch="x86_32bit"
+ fi
+
+ install -d "$pkgdir"/opt
+ cp -R "$srcdir"/Natron-$pkgver-Linux-$_source_arch "$pkgdir"/opt/natron
+
+ install -d "$pkgdir"/usr/bin
+ ln -s ../../opt/natron/Natron "$pkgdir"/usr/bin/natron
+ install -D "$srcdir"/natronIcon256_linux.png "$pkgdir"/usr/share/pixmaps/natronIcon256_linux.png
+ install -D "$srcdir"/natronProjectIcon_linux.png "$pkgdir"/usr/share/pixmaps/natronProjectIcon_linux.png
+ install -Dm644 "$srcdir"/natron.desktop "$pkgdir"/usr/share/applications/natron.desktop
+ install -D "$srcdir"/x-natron.xml "$pkgdir"/usr/share/mime/packages/x-natron.xml
+}
diff --git a/natron.desktop b/natron.desktop
new file mode 100755
index 000000000000..fc756aa9d671
--- /dev/null
+++ b/natron.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Terminal=false
+Name=Natron
+MimeType=application/x-natron
+Exec=natron %U
+GenericName=Compositing software
+Comment=Node-graph based compositing software
+Icon=natronIcon256_linux
+Categories=Graphics;2DGraphics;RasterGraphics;
+
diff --git a/natronIcon256_linux.png b/natronIcon256_linux.png
new file mode 100644
index 000000000000..ce5bbb9ec1fa
--- /dev/null
+++ b/natronIcon256_linux.png
Binary files differ
diff --git a/natronProjectIcon_linux.png b/natronProjectIcon_linux.png
new file mode 100644
index 000000000000..e9e4c78df8f2
--- /dev/null
+++ b/natronProjectIcon_linux.png
Binary files differ
diff --git a/x-natron.xml b/x-natron.xml
new file mode 100644
index 000000000000..2f6a2fc45726
--- /dev/null
+++ b/x-natron.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-natron">
+ <comment>Natron Project File</comment>
+ <icon name="natronProjectIcon_linux"/>
+ <glob-deleteall/>
+ <glob pattern="*.ntp"/>
+ </mime-type>
+</mime-info>