summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit67ec330276b1aa83977cc9a08f2b109f147d9c43 (patch)
tree5a05f6d9c91caa81492c03e55c90e42845611819
downloadaur-67ec330276b1aa83977cc9a08f2b109f147d9c43.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b2aaebca8c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-emf
+ pkgdesc = EMF and XSD frameworks for the Eclipse platform
+ pkgver = 2.10.2
+ pkgrel = 1
+ url = http://www.eclipse.org/modeling/emf/
+ arch = any
+ license = EPL
+ depends = eclipse>=3.5
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/modeling/emf/emf/downloads/drops/2.10.2/R201501230452/emf-runtime-2.10.2.zip
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/modeling/emf/emf/downloads/drops/2.10.2/R201501230452/xsd-runtime-2.10.2.zip
+ sha256sums = 1243978ebfd2de2178b72c4227d4ee47b46d1d4d13442c3f1ae0a9ec0eef42f6
+ sha256sums = 8bb29f58772f2a1a2167ff8c4b825a58fdd64923c44aec0c48d66c5afcb76fc7
+
+pkgname = eclipse-emf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4312e6368e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
+# Contributor: Stéphane Marguet (Stemp) <smarguet@gmail.com>
+# Contributor: scippio <scippio [at] berounet.cz>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: Corrado Primier <bardo@aur.archlinux.org>
+# Contributor: Rubin Simons <rubin@xs4all.nl>
+
+pkgname=eclipse-emf
+pkgver=2.10.2
+_reldate=201501230452
+pkgrel=1
+pkgdesc="EMF and XSD frameworks for the Eclipse platform"
+arch=('any')
+url="http://www.eclipse.org/modeling/emf/"
+license=('EPL')
+depends=('eclipse>=3.5')
+_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
+source=("$_mirror/modeling/emf/emf/downloads/drops/${pkgver}/R${_reldate}/emf-runtime-${pkgver}.zip"
+ "$_mirror/modeling/emf/emf/downloads/drops/${pkgver}/R${_reldate}/xsd-runtime-${pkgver}.zip")
+sha256sums=('1243978ebfd2de2178b72c4227d4ee47b46d1d4d13442c3f1ae0a9ec0eef42f6'
+ '8bb29f58772f2a1a2167ff8c4b825a58fdd64923c44aec0c48d66c5afcb76fc7')
+package() {
+ _dest="${pkgdir}"/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ cd "${srcdir}/eclipse"
+ find . -type f | while read f ; do
+ install -Dm644 ${f} "${_dest}/${f}"
+ done
+}