summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb00rt00s2015-06-08 22:26:06 +0200
committerb00rt00s2015-06-08 22:26:06 +0200
commit680e2536c5c57186c18f774effea5a67493a3acf (patch)
treed080831df1c6deafd1a6fb129ee09028db3f0a26
downloadaur-680e2536c5c57186c18f774effea5a67493a3acf.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD56
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..358f87b8f7a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 8 19:38:56 UTC 2015
+pkgbase = tcl85
+ pkgdesc = The Tcl scripting language, 8.5 series
+ pkgver = 8.5.17
+ pkgrel = 1
+ url = http://tcl.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ provides = tcl
+ provides = tcl=8.5.17
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/tcl/tcl8.5.17-src.tar.gz
+ md5sums = bac917ce5e1cf029bffc766aa884635b
+
+pkgname = tcl85
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3565eb18dc9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: b00rt00s ( bomby dot zrzuc at gmail dot com )
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Weng Xuetian <wengxt@gmail.com>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=tcl85
+pkgver=8.5.17
+pkgrel=1
+pkgdesc="The Tcl scripting language, 8.5 series"
+arch=('i686' 'x86_64')
+url="http://tcl.sourceforge.net/"
+license=('custom')
+provides=("tcl" "tcl=${pkgver}")
+source=(http://downloads.sourceforge.net/sourceforge/tcl/tcl${pkgver}-src.tar.gz)
+md5sums=('bac917ce5e1cf029bffc766aa884635b')
+options=('staticlibs')
+
+build() {
+ cd ${srcdir}/tcl${pkgver}/unix
+
+ # we build the tcl sqlite interface in sqlite-tcl package
+ rm -rf ${srcdir}/tcl${pkgver}/pkgs/sqlite3*
+
+ [[ $CARCH == "x86_64" ]] && BIT="--enable-64bit"
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-threads $BIT \
+ --includedir=/usr/include/tcl8.5
+
+ make
+}
+
+check() {
+ cd ${srcdir}/tcl${pkgver}/unix
+ make test
+}
+
+package()
+{
+ cd ${srcdir}/tcl${pkgver}/unix
+
+ make INSTALL_ROOT=${pkgdir} install install-private-headers
+ ln -s libtcl8.5.so "${pkgdir}/usr/lib/libtcl8.5.so.0"
+
+ # install license
+ install -Dm644 ../license.terms ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -r ${pkgdir}/usr/share/man
+ mv ${pkgdir}/usr/lib/tcl8/ ${pkgdir}/usr/lib/tcl8.5/
+ sed -i -e's:variable paths {}:variable paths {/usr/lib/tcl$(v)/tcl8}:' \
+ ${pkgdir}/usr/lib/tcl8.5/tm.tcl
+
+ # remove buildroot traces
+ sed -i "s#${srcdir}#/usr/src#" ${pkgdir}/usr/lib/tclConfig.sh
+ mv ${pkgdir}/usr/lib/tclConfig.sh ${pkgdir}/usr/lib/tcl8.5/
+
+ # rename files
+ mv ${pkgdir}/usr/lib/pkgconfig/tcl.pc ${pkgdir}/usr/lib/pkgconfig/tcl85.pc
+}