summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDicebot2015-06-14 14:59:30 +0300
committerDicebot2015-06-14 15:00:14 +0300
commit68585a85e2ce37975123b6084e2f7730743a920a (patch)
tree528331173080a7377d88cc516a681c682ede18b6
downloadaur-68585a85e2ce37975123b6084e2f7730743a920a.tar.gz
Initial package for Digger (2.2)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--digger.ini50
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5254f541f96a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dlang-digger
+ pkgdesc = A tool to build D and bisect old D versions
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://github.com/CyberShadow/Digger
+ arch = i686
+ arch = x86_64
+ groups = dlang
+ license = custom
+ makedepends = git
+ makedepends = dmd
+ makedepends = libphobos-devel
+ makedepends = dtools
+ depends = git
+ backup = etc/digger.ini
+ source = git+https://github.com/CyberShadow/Digger.git#tag=2.2
+ source = digger.ini
+ sha256sums = SKIP
+ sha256sums = 8077a00ca2c6b41ec2a8175a2fb7114787d076627d49f9374ddbbd2394ed9e8f
+
+pkgname = dlang-digger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3c815626b2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Dicebot <public@dicebot.lv>
+pkgname=dlang-digger
+pkgver=2.2
+pkgrel=1
+pkgdesc="A tool to build D and bisect old D versions"
+arch=('i686' 'x86_64')
+groups=('dlang')
+url="https://github.com/CyberShadow/Digger"
+license=('custom')
+depends=('git')
+makedepends=('git' 'dmd' 'libphobos-devel' 'dtools')
+source=(
+ "git+https://github.com/CyberShadow/Digger.git#tag=${pkgver//_/-}"
+ 'digger.ini'
+)
+sha256sums=(
+ 'SKIP'
+ '8077a00ca2c6b41ec2a8175a2fb7114787d076627d49f9374ddbbd2394ed9e8f'
+)
+backup=(
+ 'etc/digger.ini'
+)
+
+build ()
+{
+ cd $srcdir/Digger
+ git submodule update --init
+ rdmd -g --compiler=dmd --build-only digger.d
+}
+
+package ()
+{
+ mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/doc/digger $pkgdir/usr/share/licenses/digger $pkgdir/etc
+
+ install -m755 $srcdir/Digger/digger $pkgdir/usr/bin/digger
+ install -m644 $srcdir/digger.ini $pkgdir/etc/digger.ini
+ install -m644 $srcdir/Digger/bisect.ini.sample $pkgdir/usr/share/doc/digger/bisect.ini.sample
+ install -m644 $srcdir/Digger/LICENSE.md $pkgdir/usr/share/licenses/digger/LICENSE
+}
diff --git a/digger.ini b/digger.ini
new file mode 100644
index 000000000000..922bad0d4369
--- /dev/null
+++ b/digger.ini
@@ -0,0 +1,50 @@
+# Working directory.
+# This directory will contain all of Digger's working files:
+# the D repositories, any build prerequisites obtained
+# automatically, the current build output, and the cache, if
+# enabled.
+# Please specify an absolute path. The default is to use the
+# current directory.
+
+workDir = ~/.cache/digger/
+
+# Build cache.
+# To speed up successive runs, Digger can save the results of
+# each commit's build. The downside is that this uses up disk
+# space. The following cache engines are available:
+# - none No persistent cache.
+# - directory Store built files in a directory tree.
+# Saves some disk space by hard-linking identical
+# files.
+# - git Use a git repository (and git's deduplication /
+# compression mechanisms). Uses much less disk
+# space than "directory", but is a little slower.
+# You can periodically run "digger compact" to optimize disk
+# space used by the cache.
+
+cache = git
+
+# Build/test environment.
+# By default, Digger completely clears the environment and
+# builds a new one from scratch, to avoid potential sources
+# of contamination that can affect the D builds or test results.
+# The environment is calculated in this order:
+# 1. Clear entirely
+# 2. Build minimal environment
+# 3. Apply digger.ini settings
+# 4. Apply bisect.ini settings, if we are bisecting
+# Step 4 is only applied during the execution of the test command.
+
+[environment]
+
+# You can use %VAR% syntax to refer to the previous value of a
+# variable, or if there wasn't one, to the value from the
+# original environment (before it was cleared and rebuilt).
+
+# Examples:
+
+# Add something to PATH
+#PATH=%PATH%;C:\Tools
+
+# Import PATHEXT from the original environment
+#PATHEXT=%PATHEXT%