summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-11-04 16:43:49 +0100
committeraksr2015-11-04 16:43:49 +0100
commit686394d129aed546eb3ac18124fb9fa3def3accc (patch)
tree8505ace7bbc99157c97cd4a7fc95ebc7a1483adf
downloadaur-686394d129aed546eb3ac18124fb9fa3def3accc.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--config.diff51
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b7f4b652d58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = heirloom-doctools-cvs
+ pkgdesc = The Heirloom Documentation Tools consist of a modern roff suite.
+ pkgver = 20120529
+ pkgrel = 1
+ url = http://heirloom.sourceforge.net/doctools.html
+ arch = i686
+ arch = x86_64
+ license = custom:"caldera"
+ license = custom:"opensolaris"
+ license = custom:"lucent"
+ makedepends = cvs
+ source = config.diff
+ md5sums = ccb66e215599cab347132e2f3240156e
+ sha1sums = 5b7205e61227aceb81599bdb6a2a2c457d79a016
+ sha256sums = c6270ae3abdae91eb9adbdd093b33c9de758b0b31db397d3d406ac6ee16423af
+
+pkgname = heirloom-doctools-cvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09da1a55f00b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributed by; Jens Staal <staal1978@gmail.com>
+# Contributor: Sascha Biermmanns <saschakb at gmail dot com>
+# Contributor: itikhonov
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=heirloom-doctools-cvs
+pkgver=20120529
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="The Heirloom Documentation Tools consist of a modern roff suite."
+url="http://heirloom.sourceforge.net/doctools.html"
+license=('custom:"caldera"' 'custom:"opensolaris"' 'custom:"lucent"')
+source=('config.diff')
+makedepends=('cvs')
+md5sums=('ccb66e215599cab347132e2f3240156e')
+sha1sums=('5b7205e61227aceb81599bdb6a2a2c457d79a016')
+sha256sums=('c6270ae3abdae91eb9adbdd093b33c9de758b0b31db397d3d406ac6ee16423af')
+
+prepare() {
+ cvs -d:pserver:anonymous:@heirloom.cvs.sourceforge.net:/cvsroot/heirloom login
+ cvs -d:pserver:anonymous:@heirloom.cvs.sourceforge.net:/cvsroot/heirloom co -P heirloom-doctools
+ rm -rf $srcdir/build
+ cp -ar $srcdir/heirloom-doctools $srcdir/build
+ cd $srcdir/build
+ patch -p1 < ../config.diff
+}
+
+build() {
+ cd $srcdir/build
+ make
+}
+
+package() {
+ cd $srcdir/build
+ make install ROOT=$pkgdir
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ cd "$srcdir/heirloom-doctools/LICENSE"
+ install -m0644 CALDERA.LICENSE $pkgdir/usr/share/licenses/${pkgname}/CALDERA.LICENSE
+ install -m0644 OPENSOLARIS.LICENSE $pkgdir/usr/share/licenses/${pkgname}/OPENSOLARIS.LICENSE
+ install -m0644 LUCENT.LICENSE $pkgdir/usr/share/licenses/${pkgname}/LUCENT.LICENSE
+}
+
diff --git a/config.diff b/config.diff
new file mode 100644
index 000000000000..5e93c2fa01d6
--- /dev/null
+++ b/config.diff
@@ -0,0 +1,51 @@
+diff -ru heirloom-doctools.bak/mk.config heirloom-doctools/mk.config
+--- heirloom-doctools.bak/mk.config 2010-12-21 15:12:01.000000000 -0430
++++ heirloom-doctools/mk.config 2010-12-21 15:13:12.693333341 -0430
+@@ -1,32 +1,32 @@
+ #
+ # A BSD-compatible install command.
+ #
+-INSTALL=/usr/ucb/install
++INSTALL=/usr/bin/install
+
+ #
+ # Packaging prefix.
+ #
+-PREFIX=/usr
++PREFIX=/usr/heirloom
+
+ #
+ # Where to place binaries.
+ #
+-BINDIR=$(PREFIX)/ucb
++BINDIR=$(PREFIX)/bin/ucb
+
+ #
+ # Where to place libraries.
+ #
+-LIBDIR=$(PREFIX)/ucblib
++LIBDIR=$(PREFIX)/lib
+
+ #
+ # Where to place ASCII charts and the like.
+ #
+-PUBDIR=$(PREFIX)/pub
++PUBDIR=$(LIBDIR)/doctools/pub
+
+ #
+ # Where to place manual pages.
+ #
+-MANDIR=$(PREFIX)/share/man/5man
++MANDIR=$(PREFIX)/share/man
+
+ #
+ # Where to place the troff macro packages.
+@@ -111,7 +111,7 @@
+ #
+ # A Bourne-compatible shell.
+ #
+-SHELL=/sbin/sh
++SHELL=/bin/sh
+
+ #
+ # Run ranlib if it is in the current path. This should take care