summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2019-11-22 19:39:23 +0000
committerJoaquim Monteiro2019-11-22 19:39:23 +0000
commit68aeaa4d6798a7e737564bc75570b0200e245f26 (patch)
treeb8992209bac41b027553887e3fcba07bcf8b9d90
downloadaur-68aeaa4d6798a7e737564bc75570b0200e245f26.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6262b0b6d0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-asyncqt
+ pkgdesc = Implementation of the PEP 3156 Event-Loop with Qt (with PySide2 support)
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/gmarull/asyncqt
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-pyqt5: PyQt5 support
+ optdepends = pyside2: PySide2 support
+ source = https://github.com/gmarull/asyncqt/archive/v0.7.0.tar.gz
+ sha512sums = ca6a52d1dd69ce681dcb61610822a2bb13690e9a320587bb8054d6baafb560b8d4735ad36f4cf18ad3b0ec1841903549afcd6826914d778aeaac95fdf27becc9
+
+pkgname = python-asyncqt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d78c8370330
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0d3c7e4e906
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: gmes78 <gmes.078 at gmail dot com>
+
+pkgname=python-asyncqt
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Implementation of the PEP 3156 Event-Loop with Qt (with PySide2 support)"
+arch=(any)
+url="https://github.com/gmarull/asyncqt"
+license=("BSD")
+
+depends=("python")
+makedepends=("python-setuptools")
+optdepends=("python-pyqt5: PyQt5 support"
+ "pyside2: PySide2 support")
+
+source=("https://github.com/gmarull/asyncqt/archive/v${pkgver}.tar.gz")
+sha512sums=("ca6a52d1dd69ce681dcb61610822a2bb13690e9a320587bb8054d6baafb560b8d4735ad36f4cf18ad3b0ec1841903549afcd6826914d778aeaac95fdf27becc9")
+
+package() {
+ cd "asyncqt-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+}