summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-08-25 00:36:24 +0200
committerChristopher Arndt2020-08-25 00:36:24 +0200
commit68baae23d1e37b7668d7fcfeffe0d5694fd8de9b (patch)
tree80ef67a50b6cd14bc176f5d343fb1d208e2f3a7e
parent8644fd62f59e4e0e35761d3e8044f5a4f1ee4f11 (diff)
downloadaur-68baae23d1e37b7668d7fcfeffe0d5694fd8de9b.tar.gz
New upstream version and various PKGBUILD improvements
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD67
3 files changed, 51 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1433f3ad562..7a6f771d48bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,23 @@
pkgbase = bchoppr-git
- pkgdesc = An audio stream chopping LV2 plugin.
- pkgver = r133.510ab2a
+ pkgdesc = An audio stream chopping LV2 plugin (git version)
+ pkgver = 1.8.0.r0.g7fb0af3
pkgrel = 1
url = https://github.com/sjaehn/BChoppr
arch = x86_64
- license = GPL
- depends = xorg-server
+ groups = lv2-plugins
+ groups = pro-audio
+ license = GPL3
+ checkdepends = lv2lint
+ makedepends = git
+ makedepends = lv2
depends = cairo
- depends = lv2
- source = git+https://github.com/sjaehn/BChoppr
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ provides = bchoppr
+ provides = bchoppr=1.8.0
+ conflicts = bchoppr
+ source = bchoppr::git+https://github.com/sjaehn/BChoppr
md5sums = SKIP
pkgname = bchoppr-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3b3941339e14
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+bchoppr/
+pkg/
+src/
+bchoppr-git-*.pkg.tar.xz
+bchoppr-git-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 86052aebcb1c..03063ca92f2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,48 @@
# Maintainer: Milk Brewster (milkii on freenode irc)
-pkgname=bchoppr-git
-pkgver=r133.510ab2a
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name="BChoppr"
+_pkgname="${_name,,}"
+_plugin_uri="https://www.jahnichen.de/plugins/lv2/${_name}"
+pkgname="${_pkgname}-git"
+pkgver=1.8.0.r0.g7fb0af3
pkgrel=1
-epoch=
-pkgdesc="An audio stream chopping LV2 plugin."
+pkgdesc="An audio stream chopping LV2 plugin (git version)"
arch=('x86_64')
-url="https://github.com/sjaehn/BChoppr"
-license=('GPL')
-groups=()
-depends=('xorg-server' 'cairo' 'lv2')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("git+https://github.com/sjaehn/BChoppr")
-noextract=()
+url="https://github.com/sjaehn/${_name}"
+license=('GPL3')
+groups=('lv2-plugins' 'pro-audio')
+depends=('cairo' 'gcc-libs' 'glibc' 'libx11')
+makedepends=('git' 'lv2')
+checkdepends=('lv2lint')
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/sjaehn/${_name}")
md5sums=('SKIP')
-validpgpkeys=()
-# prepare() {
-# }
pkgver() {
- cd "$srcdir"/BChoppr
+ cd "${srcdir}/$_pkgname"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
- }
-
+}
build() {
- cd "$srcdir"/BChoppr
+ cd "${srcdir}/$_pkgname"
make
}
-
-# check() {
- # cd "$pkgname-$pkgver"
- # make -k check
-# }
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ lv2lint -Mpack -I "${_name}.lv2/" "${_plugin_uri}"
+}
package() {
- cd "$srcdir"/BChoppr
- # make INSTALL_DIR="${pkgdir}/usr/lib/lv2" install
- make PREFIX="${pkgdir}/usr" install
+ cd "$_pkgname"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ # Remove useless license file
+ find "${pkgdir}/usr/lib/" -type f -iname "*LICENSE*" -delete
}