summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Wallace2016-02-20 18:10:29 -0800
committerColin Wallace2016-02-20 19:31:29 -0800
commit68f1270ed88d8f7d87d96c70d492ac762b356dec (patch)
tree3f7bd959df5d9ef6e79c7485bfc2b50f51b0f233
downloadaur-68f1270ed88d8f7d87d96c70d492ac762b356dec.tar.gz
First version; link against sparrow dynamically
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--sparrow-dyn.patch11
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40d8dec81531
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Feb 21 03:27:54 UTC 2016
+pkgbase = hase-git
+ pkgdesc = Gravity artillery shooter game
+ pkgver = 341.da32fd2
+ pkgrel = 1
+ url = http://ziz.gp2x.de/hase/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = sparrow3d
+ provides = hase
+ source = git+https://github.com/theZiz/hase.git
+ source = sparrow-dyn.patch
+ md5sums = SKIP
+ md5sums = f71a4a3fb0569eaf3d66c818b1f8470c
+
+pkgname = hase-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9096711dc8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Colin Wallace <wallacoloo@gmail.com>
+
+pkgname=hase-git
+pkgver=341.da32fd2
+pkgrel=1
+pkgdesc='Gravity artillery shooter game'
+arch=('any')
+url='http://ziz.gp2x.de/hase/'
+license=('GPL')
+depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_net' 'sparrow3d')
+makedepends=('git')
+provides=('hase')
+source=("git+https://github.com/theZiz/hase.git" "sparrow-dyn.patch")
+md5sums=('SKIP' 'f71a4a3fb0569eaf3d66c818b1f8470c')
+
+pkgver() {
+ cd "$srcdir"/hase
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+prepare() {
+ cd "$srcdir"/hase
+ # Patch hase to link against sparrow dynamically
+ patch -p1 -i "$srcdir"/sparrow-dyn.patch Makefile
+}
+
+build() {
+ cd "$srcdir"/hase
+ make
+}
+
+package() {
+ cd "$srcdir"/hase
+ # Make directories that the install script expects to already exist
+ mkdir -p "$pkgdir"/usr/{bin,share,share/applications,share/pixmaps}
+ ./install.sh "$pkgdir"/usr
+}
diff --git a/sparrow-dyn.patch b/sparrow-dyn.patch
new file mode 100644
index 000000000000..c72841e99239
--- /dev/null
+++ b/sparrow-dyn.patch
@@ -0,0 +1,11 @@
+--- Makefile 2016-02-20 18:11:17.049481381 -0800
++++ Makefile.new 2016-02-20 19:09:07.242806337 -0800
+@@ -35,7 +35,7 @@
+ LIB += -L$(SPARROW_LIB)
+ INCLUDE += -I$(SPARROW_FOLDER)
+
+-HASE_STATIC = $(SPARROW_LIB)/$(SPARROW3D_STATIC_LIB) $(SPARROW_LIB)/$(SPARROWSOUND_STATIC_LIB) $(SPARROW_LIB)/$(SPARROWNET_STATIC_LIB) $(STATIC)
++DYNAMIC += -lsparrow3d -lsparrowNet -lsparrowSound
+
+ ifneq ($(TARGET),win32)
+ DYNAMIC += -lz