summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-18 18:28:34 +0200
committerGoliathLabs2020-05-18 18:28:34 +0200
commit68f625fd01a585309295f0463e4f4c547f70d834 (patch)
treecfb87ded1572296692d8c65d0a25e01e28437ac6
parent3d1d156fae363f4e9d95485b23194cac0125bad9 (diff)
downloadaur-68f625fd01a585309295f0463e4f4c547f70d834.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD24
-rw-r--r--squidguard-patch.diff11
3 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 138dc95ee1f9..cb86cb359534 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = squidguard
pkgdesc = Filter and redirector plugin for Squid. SquidGuard is a free, flexible and ultra fast filter, redirector and access controller plugin for squid.
pkgver = 1.6.0
- pkgrel = 6
+ pkgrel = 7
url = http://www.squidguard.org
install = squidguard.install
arch = x86_64
+ arch = i686
groups =
license = GPL
depends = db
diff --git a/PKGBUILD b/PKGBUILD
index 6a9821317423..b8fcec47c60a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: TheGoliath
-# Contributor: TheGoliath
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: derhomp <nick at nickz dot org>
+
pkgname=squidguard
pkgver=1.6.0
-pkgrel=6
+pkgrel=7
pkgdesc="Filter and redirector plugin for Squid. SquidGuard is a free, flexible and ultra fast filter, redirector and access controller plugin for squid."
-arch=('x86_64')
+arch=('x86_64' 'i686')
url="http://www.squidguard.org"
license=('GPL')
groups=('')
@@ -15,20 +16,17 @@ backup=('etc/logrotate.d/squidguard' 'etc/squidguard/squidGuard.conf.default')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("https://launchpad.net/debian/+archive/primary/+sourcefiles/squidguard/$pkgver-1/squidguard_$pkgver.orig.tar.gz")
-# "squidguard-patch.diff")
sha512sums=('d6e934f550cd777d58abda5f4fd905ccc396afc28e1ddb0bb842a9a3364cbe43db5c30834fe1ed7d93623a361dde50362a79ac2b660382c7e81b4f067f2ac65e')
-# '1e7a1bdc1000b6b944acdf1ff5a339d586ad99597e09e83807c7221f24b230281899a0dc82e5aebaf2553ee5fddc3a9d54f30707c9b29285beb8a0685001c4ab')
-#prepare() {
-# cd "${srcdir}/${pkgname}-${pkgver}"
-#
-# patch -p0 -i "${srcdir}/squidguard-patch.diff"
-#}
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i '19,24 s/@[se]/$(DESTDIR)&/; /SQUIDUSER/d; 51d' Makefile.in
+}
build() {
cd "${srcdir}/${pkgname}-$pkgver"
./autogen.sh
- sed -i '19,24 s/@[se]/$(DESTDIR)&/; /SQUIDUSER/d; 51d' Makefile.in
./configure \
--prefix=/usr \
--with-sg-config=/etc/squidGuard/squidGuard.conf \
@@ -39,6 +37,6 @@ build() {
}
package() {
- cd "squidguard-$pkgver"
+ cd "${srcdir}/${pkgname}-$pkgver"
make DESTDIR="$pkgdir" install
}
diff --git a/squidguard-patch.diff b/squidguard-patch.diff
deleted file mode 100644
index 8c237343d09b..000000000000
--- a/squidguard-patch.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/sgDb.c 2010-09-09 12:35:22.000000000 +0200
-+++ src/sgDb.c 2017-09-17 19:27:47.347261770 +0200
-@@ -112,7 +112,7 @@
- }
- }
- #endif
--#if DB_VERSION_MAJOR == 4
-+#if DB_VERSION_MAJOR >= 4
- if(globalUpdate || createdb || (dbfile != NULL && stat(dbfile,&st))){
- flag = DB_CREATE;
- if(createdb)