summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-03-17 10:30:38 +0100
committerMarius Kittler2023-03-17 10:30:38 +0100
commit6936886c4e8c1f07d4db5dda9a4571448e40d1ab (patch)
treee5035d929146a3a7466055f46104c42a9d9abdec
parent37fd600cfaf44910d9a8934860dfc75922228a37 (diff)
downloadaur-6936886c4e8c1f07d4db5dda9a4571448e40d1ab.tar.gz
Rebuild against ffmpeg 6
-rw-r--r--.SRCINFO5
-rw-r--r--12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch25
-rw-r--r--PKGBUILD9
3 files changed, 35 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0aeb9510ca98..6332c0ae7b93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = subtitlecomposer
pkgdesc = Video subtitle editor
pkgver = 0.7.1
- pkgrel = 5
+ pkgrel = 6
url = https://invent.kde.org/multimedia/
arch = i686
arch = x86_64
@@ -26,10 +26,13 @@ pkgbase = subtitlecomposer
source = https://download.kde.org/stable/subtitlecomposer/subtitlecomposer-0.7.1.tar.xz.sig
source = 4f4f560e40ba0b760cf688eb024be3cc734ca347.patch
source = d8f9797d9c0d45fa9f4402f79c539544b74d2cc7.patch
+ source = 12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch
validpgpkeys = 76F79007A54A4B68F1547928E2418746EF9D9B26
sha256sums = ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255
sha256sums = SKIP
sha256sums = 26197260a6e4419c7178c65a5ac9e8811418e40c97454b2aa8a62b149305dcd5
sha256sums = 9df3e453d04e74a49c11ff67dbd8d9460d92744636769bf04e898f16b73124d5
+ sha256sums = c570f7164d9b93c1a437d71f948f3c26a20725c78a32548e00013d9f1528e7c6
pkgname = subtitlecomposer
+
diff --git a/12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch b/12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch
new file mode 100644
index 000000000000..7e0d873992a5
--- /dev/null
+++ b/12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch
@@ -0,0 +1,25 @@
+From 12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Sat, 4 Mar 2023 10:58:04 +0100
+Subject: [PATCH] Use non deprecated ffmpeg api
+
+---
+ src/videoplayer/backend/streamdemuxer.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/videoplayer/backend/streamdemuxer.cpp b/src/videoplayer/backend/streamdemuxer.cpp
+index e3bd808a..39222d8c 100644
+--- a/src/videoplayer/backend/streamdemuxer.cpp
++++ b/src/videoplayer/backend/streamdemuxer.cpp
+@@ -504,7 +504,7 @@ StreamDemuxer::run()
+
+ { // find_stream_info
+ const int origNbStreams = ic->nb_streams;
+- AVDictionary **opts = (AVDictionary **)av_mallocz_array(origNbStreams, sizeof(*opts));
++ AVDictionary **opts = (AVDictionary **)av_calloc(origNbStreams, sizeof(*opts));
+ if(!opts) {
+ av_log(nullptr, AV_LOG_ERROR, "Could not alloc memory for stream options.\n");
+ goto cleanup;
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index 63795f87f0d6..189129fa016e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=subtitlecomposer
pkgver=0.7.1
-pkgrel=5
+pkgrel=6
pkgdesc='Video subtitle editor'
arch=('i686' 'x86_64')
url="https://invent.kde.org/multimedia/${_name}"
@@ -36,17 +36,20 @@ _tar=${pkgname}-${pkgver}
source=("https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz"
"https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz.sig"
"4f4f560e40ba0b760cf688eb024be3cc734ca347.patch"
- "d8f9797d9c0d45fa9f4402f79c539544b74d2cc7.patch")
+ "d8f9797d9c0d45fa9f4402f79c539544b74d2cc7.patch"
+ "12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch")
sha256sums=('ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255'
'SKIP'
'26197260a6e4419c7178c65a5ac9e8811418e40c97454b2aa8a62b149305dcd5'
- '9df3e453d04e74a49c11ff67dbd8d9460d92744636769bf04e898f16b73124d5')
+ '9df3e453d04e74a49c11ff67dbd8d9460d92744636769bf04e898f16b73124d5'
+ 'c570f7164d9b93c1a437d71f948f3c26a20725c78a32548e00013d9f1528e7c6')
validpgpkeys=('76F79007A54A4B68F1547928E2418746EF9D9B26')
prepare() {
cd "${srcdir}/${_tar}"
patch -p1 -i "$srcdir/4f4f560e40ba0b760cf688eb024be3cc734ca347.patch"
patch -p1 -i "$srcdir/d8f9797d9c0d45fa9f4402f79c539544b74d2cc7.patch"
+ patch -p1 -i "$srcdir/12f4d7f49d0b1a7fc02b0836521a285e7b6bac9d.patch"
}
build() {