summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2023-09-02 14:39:15 +0200
committerFrederic Bezies2023-09-02 14:39:15 +0200
commit693fd99674284ae2867fc1fa86697b03957d397a (patch)
tree84fb48d1391f3ca3cfb7d91bc6a19acd9ef3dc5f
parent2faf205507ced417693610ed1fe8a7335ce4b255 (diff)
downloadaur-693fd99674284ae2867fc1fa86697b03957d397a.tar.gz
2023.09.01 update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b9136fb3573..e3cd751c9980 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x-sdl2
pkgdesc = x86 emulator with builtin DOS, with patches and more features
- pkgver = 2023.05.01
+ pkgver = 2023.09.01
pkgrel = 1
url = http://dosbox-x.com
arch = i686
@@ -16,7 +16,7 @@ pkgbase = dosbox-x-sdl2
conflicts = dosbox-x-git
conflicts = dosbox-x
conflicts = dosbox-x-sdl2-git
- source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v2023.05.01.tar.gz
- sha256sums = 0aa75b873978aec41ecfee62bb103d8a17fe3566a3ebf5415245cee0dd032ebb
+ source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v2023.09.01.tar.gz
+ sha256sums = 71bf4477ae1640406fa24023f51766ab158ebf26f0e2f317f6fd7bd84c15b4e6
pkgname = dosbox-x-sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 4152854fbb84..79a11656385f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
pkgname=dosbox-x-sdl2
-pkgver=2023.05.01
+_pkgname=dosbox-x
+pkgver=2023.09.01
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches and more features"
arch=(i686 x86_64 aarch64)
@@ -12,15 +13,28 @@ makedepends=(glu)
optdepends=()
conflicts=('dosbox-x-git' 'dosbox-x' 'dosbox-x-sdl2-git')
source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz)
-sha256sums=('0aa75b873978aec41ecfee62bb103d8a17fe3566a3ebf5415245cee0dd032ebb')
+sha256sums=('71bf4477ae1640406fa24023f51766ab158ebf26f0e2f317f6fd7bd84c15b4e6')
+
+# Using git source to work around bug 4436: https://github.com/joncampbell123/dosbox-x/issues/4436
build() {
cd "$srcdir/dosbox-x-dosbox-x-v$pkgver"
+
./autogen.sh
+
+ # Working around bug 4436: https://github.com/joncampbell123/dosbox-x/issues/4436
+ # We need to deactivate -Werror=format-security
+
+ export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat \
+ -fstack-clash-protection -fcf-protection"
+ export CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
export LDFLAGS="${LDFLAGS//,--as-needed}"
+
chmod +x configure
./configure --enable-core-inline --enable-debug --enable-avcodec --prefix=/usr --enable-sdl2
make -j$(nproc)
+
}
package() {