summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Dallilar2018-05-26 03:18:59 -0400
committerYigit Dallilar2018-05-26 03:18:59 -0400
commit69428cf453b887b762b6da2b668dbfe835fb4be6 (patch)
tree8c2e7cbce3cf94dc70abdce77b57a89eb63debb3
parent22207302d7824c0479aa5a356fff6a39ee1b0dd3 (diff)
downloadaur-69428cf453b887b762b6da2b668dbfe835fb4be6.tar.gz
adopt the package and upgrade to version 0.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--slack-term.json76
3 files changed, 96 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a26fa32cf50..44f069d4f6dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = slack-term
pkgdesc = Slack client for your terminal
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/erroneousboat/slack-term
arch = x86_64
license = MIT
- makedepends = git
- options = !strip
- options = !emptydirs
- source = git+https://github.com/erroneousboat/slack-term
- source = https://github.com/erroneousboat/slack-term/releases/download/v0.3.0/slack-term-linux-amd64
- sha256sums = SKIP
- sha256sums = bc669111389a0c4cc244d9e5eb0660c75a7d946c00e6986f3238e9103f0bd42c
+ source = https://raw.githubusercontent.com/erroneousboat/slack-term/master/LICENSE
+ source = slack-term::https://github.com/erroneousboat/slack-term/releases/download/v0.4.0/slack-term-linux-amd64
+ source = slack-term.json
+ md5sums = 563e9d16dfa4d970c956ebc0e6e140dd
+ md5sums = 8db633b31bc1b2823da0155ab93e3427
+ md5sums = 9cdd35c2d48f6d899333ab3721a6464b
pkgname = slack-term
diff --git a/PKGBUILD b/PKGBUILD
index 4d9a89501e9e..1e439cd523eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: orumin <dev at orum.in>
+# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
+# Prev. Maintainer: orumin <dev at orum.in>
pkgname=slack-term
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="Slack client for your terminal"
arch=('x86_64')
url="https://github.com/erroneousboat/slack-term"
-source=("git+$url"
- "$url/releases/download/v${pkgver}/slack-term-linux-amd64")
-sha256sums=('SKIP'
- 'bc669111389a0c4cc244d9e5eb0660c75a7d946c00e6986f3238e9103f0bd42c')
+source=("https://raw.githubusercontent.com/erroneousboat/slack-term/master/LICENSE"
+ "slack-term::${url}/releases/download/v${pkgver}/slack-term-linux-amd64"
+ "slack-term.json")
license=('MIT')
-makedepends=('git')
-options=('!strip' '!emptydirs')
-
-prepare() {
- cd "$srcdir/$pkgname"
- git checkout v$pkgver
-}
+options=()
+md5sums=('563e9d16dfa4d970c956ebc0e6e140dd'
+ '8db633b31bc1b2823da0155ab93e3427'
+ '9cdd35c2d48f6d899333ab3721a6464b')
package() {
- install -p -Dm755 "$srcdir/slack-term-linux-amd64" "$pkgdir/usr/bin/slack-term"
- cd "$srcdir/$pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 slack-term ${pkgdir}/usr/bin/slack-term
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 slack-term.json ${pkgdir}/etc/slack-term.json
}
# vim:set ts=2 sw=2 et:
diff --git a/slack-term.json b/slack-term.json
new file mode 100644
index 000000000000..e39b1271ad60
--- /dev/null
+++ b/slack-term.json
@@ -0,0 +1,76 @@
+{
+ "slack_token": "yourslacktokenhere",
+
+ // OPTIONAL: set the width of the sidebar (between 1 and 11), default is 1
+ "sidebar_width": 1,
+
+ // OPTIONAL: turn on desktop notifications for all incoming messages, set
+ // the value as: "all", and for only mentions and im messages set the
+ // value as: "mention", default is turned off: ""
+ "notify": "",
+
+ // OPTIONAL: define custom key mappings, defaults are:
+ "key_map": {
+ "command": {
+ "i": "mode-insert",
+ "/": "mode-search",
+ "k": "channel-up",
+ "j": "channel-down",
+ "g": "channel-top",
+ "G": "channel-bottom",
+ "<previous>": "chat-up",
+ "C-b": "chat-up",
+ "C-u": "chat-up",
+ "<next>": "chat-down",
+ "C-f": "chat-down",
+ "C-d": "chat-down",
+ "n": "channel-search-next",
+ "N": "channel-search-previous",
+ "q": "quit",
+ "<f1>": "help"
+ },
+ "insert": {
+ "<left>": "cursor-left",
+ "<right>": "cursor-right",
+ "<enter>": "send",
+ "<escape>": "mode-command",
+ "<backspace>": "backspace",
+ "C-8": "backspace",
+ "<delete>": "delete",
+ "<space>": "space"
+ },
+ "search": {
+ "<left>": "cursor-left",
+ "<right>": "cursor-right",
+ "<escape>": "clear-input",
+ "<enter>": "clear-input",
+ "<backspace>": "backspace",
+ "C-8": "backspace",
+ "<delete>": "delete",
+ "<space>": "space"
+ }
+ },
+
+ // OPTIONAL: override the default theme (see wiki for more information),
+ // defaults are:
+ "theme": {
+ "view": {
+ "fg": "white",
+ "bg": "default",
+ "border_fg": "white",
+ "border_bg": "white",
+ "par_fg": "white",
+ "par_label_fg": "white"
+ },
+ "channel": {
+ "prefix": "",
+ "icon": "",
+ "text": ""
+ },
+ "message": {
+ "time": "",
+ "name": "",
+ "text": ""
+ }
+ }
+}