summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:37:42 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:37:42 -0700
commit694e8695b68a76079c37d7cf9b079c135d4d7285 (patch)
treef932123e2e30e4248726c2b7412dbdc77e0b964a
downloadaur-694e8695b68a76079c37d7cf9b079c135d4d7285.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8380c2a034d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = uclibc
+ pkgdesc = C library for developing embedded Linux systems
+ pkgver = 0.9.33.2
+ pkgrel = 1
+ url = http://www.uclibc.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ source = http://www.uclibc.org/downloads/uClibc-0.9.33.2.tar.xz
+ md5sums = 73e6fe215648d02246f4d195b25fb17e
+
+pkgname = uclibc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12ef1c62dcac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: John Jenkins shaggytwodope@gmail.com
+# Contributor: Chirantan Ekbote <chirantan.ekbote at gmail.com>
+# Contributor: Bartlomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: res <andres87p@gmail.com>
+
+pkgname=uclibc
+_pkgname=${pkgname/c/C}
+pkgver=0.9.33.2
+pkgrel=1
+pkgdesc='C library for developing embedded Linux systems'
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://www.uclibc.org/"
+source=(http://www.uclibc.org/downloads/${_pkgname}-${pkgver}.tar.xz)
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ msg "Running make menuconfig"
+ make menuconfig
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make PREFIX="$pkgdir" install
+}
+
+md5sums=('73e6fe215648d02246f4d195b25fb17e')