summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Hague2023-10-28 11:55:46 +0100
committerMatthew Hague2023-10-28 11:55:46 +0100
commit695d76ddb4f8810848fb833de3f2362c37dd3037 (patch)
treef1ca2d7e594560a05dc3b97dcc0fec0776d06c64
parent19b35ddb1cc836dfda83eef32eeb784129bc73e0 (diff)
downloadaur-695d76ddb4f8810848fb833de3f2362c37dd3037.tar.gz
Fix source url and post install message
As per tzok comment on 2023-10-20 07:16 (UTC)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rw-r--r--nodejs-imapnotify-git.install2
3 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17567a8273f9..d6c7f9a82aaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Nov 1 18:01:04 UTC 2017
pkgbase = nodejs-imapnotify-git
pkgdesc = Execute scripts on new messages using IDLE imap command
- pkgver = 0.2.0.r6.ga37456c
+ pkgver = r39.f886715
pkgrel = 1
- url = http://github.com/a-sk/node-imapnotify
+ url = https://github.com/titibandit/node-imapnotify
install = nodejs-imapnotify-git.install
arch = any
license = MIT
makedepends = npm
depends = nodejs
conflicts = nodejs-imapnotify
- source = nodejs-imapnotify-git::git://github.com/a-sk/node-imapnotify.git
+ source = nodejs-imapnotify-git::git+https://github.com/titibandit/node-imapnotify
source = imapnotify@.service
sha256sums = SKIP
sha256sums = e101ef974e5c342f7a69177fb5ae1c341b4c39c911993eaa97a0917bddc5cc11
pkgname = nodejs-imapnotify-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 48b73d3c5bd3..2252e3c391b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@
_npmname=imapnotify
pkgname=nodejs-imapnotify-git
-pkgver=0.2.0.r6.ga37456c
+pkgver=r39.f886715
pkgrel=1
pkgdesc='Execute scripts on new messages using IDLE imap command'
arch=(any)
-url='http://github.com/a-sk/node-imapnotify'
+url="https://github.com/titibandit/node-imapnotify"
license=('MIT')
depends=('nodejs')
optdepends=()
makedepends=('npm')
install=$pkgname.install
conflicts=('nodejs-imapnotify')
-source=($pkgname::git://github.com/a-sk/node-imapnotify.git
+source=($pkgname::git+https://github.com/titibandit/node-imapnotify
imapnotify@.service)
sha256sums=('SKIP'
'e101ef974e5c342f7a69177fb5ae1c341b4c39c911993eaa97a0917bddc5cc11')
pkgver() {
cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
diff --git a/nodejs-imapnotify-git.install b/nodejs-imapnotify-git.install
index 2a32afa20dc7..f71777c4415b 100644
--- a/nodejs-imapnotify-git.install
+++ b/nodejs-imapnotify-git.install
@@ -13,7 +13,7 @@ BLUE="${BOLD}$(tput setaf 4)"
YELLOW="${BOLD}$(tput setaf 3)"
post_install() {
- note "To use with systemd, place a config file in ~/.config/imapnotify/<config>.json and use systemctl --user enable imapnotify@<config>"
+ note "To use with systemd, place a config file in ~/.config/imapnotify/<config>.json and use systemctl --user enable imapnotify@<config>.json"
}
post_upgrade() {