summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-04-14 09:21:23 +0200
committerJP Cimalando2018-04-14 09:21:23 +0200
commit69649329eed6e6e11589877fd8c3d44c80b2a4ca (patch)
tree8bebddc9d6e072ebec82a8f5fa3548426a3df00e
downloadaur-69649329eed6e6e11589877fd8c3d44c80b2a4ca.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
-rw-r--r--opl3_bank_editor.desktop8
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c44cf419802
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = opl3bankeditor-git
+ pkgdesc = A small cross-platform editor of the OPL3 FM banks of different formats
+ pkgver = 1.3.beta.r148.gcbca839
+ pkgrel = 1
+ url = https://github.com/Wohlstand/OPL3BankEditor
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-multimedia
+ provides = opl3bankeditor
+ conflicts = opl3bankeditor
+ source = git+https://github.com/Wohlstand/OPL3BankEditor.git
+ source = opl3_bank_editor.desktop
+ md5sums = SKIP
+ md5sums = 8eddaea4568da3d1b441473951d64116
+
+pkgname = opl3bankeditor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac426cb5874b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: JP Cimalando <jp-dev inbox.ru>
+pkgname=opl3bankeditor-git
+_pkgname=OPL3BankEditor
+pkgver=1.3.beta.r148.gcbca839
+pkgrel=1
+epoch=
+pkgdesc="A small cross-platform editor of the OPL3 FM banks of different formats"
+arch=('i686' 'x86_64')
+url="https://github.com/Wohlstand/OPL3BankEditor"
+license=('GPL3')
+groups=()
+depends=('qt5-multimedia')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=("opl3bankeditor")
+conflicts=("opl3bankeditor")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/Wohlstand/${_pkgname}.git"
+ 'opl3_bank_editor.desktop')
+noextract=()
+md5sums=('SKIP'
+ "8eddaea4568da3d1b441473951d64116")
+validpgpkeys=()
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ qmake
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ install -D -m755 bin-debug/opl3_bank_editor "$pkgdir"/usr/bin/opl3_bank_editor
+ install -D -m644 src/resources/opl3_48.png "$pkgdir"/usr/share/pixmaps/opl3_bank_editor.png
+ install -D -m644 "$srcdir"/opl3_bank_editor.desktop "$pkgdir"/usr/share/applications/opl3_bank_editor.desktop
+}
diff --git a/opl3_bank_editor.desktop b/opl3_bank_editor.desktop
new file mode 100644
index 000000000000..34f320f4400c
--- /dev/null
+++ b/opl3_bank_editor.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=OPL3 Bank Editor
+Comment=Edit OPL3 FM banks
+Icon=opl3_bank_editor
+Exec=opl3_bank_editor
+Categories=AudioVideo;Audio