summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2024-04-28 00:35:03 -0400
committerEthan Kerrick2024-04-28 00:35:03 -0400
commit6965b5c46f40fa86cc6ff51b73f5491a9d92b70e (patch)
tree621c56808c5747c1d90e3acbfdedab9d960513f9
parent7c1493a867fb80e8d8149bf08c550ce54c3b5cc7 (diff)
downloadaur-6965b5c46f40fa86cc6ff51b73f5491a9d92b70e.tar.gz
add sed to version checking
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xcheckupdate.sh4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a928a04556a..d012f069aeee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guilded
pkgdesc = Chat for Gaming Communities
pkgver = 1.0.9251387
- pkgrel = 1
+ pkgrel = 2
url = https://www.guilded.gg/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 47ed20ab93cc..8e6a7f4257b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=guilded
pkgver=1.0.9251387
-pkgrel=1
+pkgrel=2
pkgdesc="Chat for Gaming Communities"
arch=('x86_64')
url="https://www.guilded.gg/"
diff --git a/checkupdate.sh b/checkupdate.sh
index a9afbc225f01..bc177df8dece 100755
--- a/checkupdate.sh
+++ b/checkupdate.sh
@@ -14,7 +14,7 @@ hash=$(sha256sum Guilded-Linux.deb | awk '{ print $1 }')
ar x Guilded-Linux.deb
tar xzf control.tar.gz
-version=$(awk '/^Version:/ { print $2 }' control | cut -d '-' -f1)
+version=$(awk '/^Version:/ { print $2 }' control | cut -d '-' -f1 | sed s/~release//)
echo "--------------------"
echo "sha256sum: $hash"
@@ -26,4 +26,4 @@ else
fi
echo "--------------------"
-rm -rf $TMP_PATH \ No newline at end of file
+rm -rf $TMP_PATH