summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-03-02 17:53:31 -0500
committermutantmonkey2013-03-02 17:53:31 -0500
commit6967b47d7a1e17b894b858682a6301f0b46a068f (patch)
treebfa8055911ee63c524fdfef36ff28371b0b61d2b
downloadaur-6967b47d7a1e17b894b858682a6301f0b46a068f.tar.gz
import my AUR packages into git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22d7027eacca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dex-git
+ pkgdesc = A program to execute DesktopEntry files of type Application, primarily for window managers that do not implement the Freedesktop autostart specification
+ pkgver = 62.2d158ca
+ pkgrel = 1
+ url = https://github.com/jceb/dex
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python-sphinx
+ depends = python
+ provides = dex
+ conflicts = dex
+ source = git+https://github.com/jceb/dex.git
+ sha256sums = SKIP
+
+pkgname = dex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba0c1b2895d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: mutantmonkey <mutantmonkey@gmail.com>
+pkgname=dex-git
+pkgver=20111116
+pkgrel=1
+pkgdesc="A program to execute DesktopEntry files of type Application, primarily for window managers that do not implement the Freedesktop autostart specification"
+url="https://github.com/jceb/dex"
+arch=('any')
+license=('GPL2')
+depends=('python2')
+makedepends=('git')
+provides=('dex')
+conflicts=('dex')
+source=()
+md5sums=()
+sha256sums=()
+
+_gitroot="https://github.com/jceb/dex.git"
+_gitname="dex"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ sed -i 's/\/usr\/bin\/python/\/usr\/bin\/python2/' dex || return 1
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -m755 -D dex $pkgdir/usr/bin/dex
+}
+
+# vim:set ts=2 sw=2 et: