summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-04-09 08:00:27 +0200
committerCarl Smedstad2024-04-09 08:28:54 +0200
commit698aa1c991a29d204bfb5cbc1c07116dfecb761d (patch)
tree6220841e1cd0fddf78fdd9e0a7b419c5ca50b1e9
parent3e81200edadc036cd7d366cd6f716736e64bd766 (diff)
downloadaur-698aa1c991a29d204bfb5cbc1c07116dfecb761d.tar.gz
upgpkg: 5.13.0-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD70
2 files changed, 40 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31b1b665cfd9..7ce3b7cb3414 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pymc
pkgdesc = Markov chain Monte Carlo for Python
- pkgver = 5.11.0
+ pkgver = 5.13.0
pkgrel = 1
url = https://github.com/pymc-devs/pymc
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-pymc
depends = python-arviz
depends = python-cachetools
depends = python-cloudpickle
- depends = python-fastprogress
+ depends = python-dm-tree
depends = python-graphviz
depends = python-matplotlib
depends = python-networkx
@@ -22,10 +22,11 @@ pkgbase = python-pymc
depends = python-pandas
depends = python-pytensor
depends = python-pytest
+ depends = python-rich
depends = python-scipy
depends = python-typing_extensions
depends = python-xarray
- source = python-pymc-5.11.0.tar.gz::https://github.com/pymc-devs/pymc/archive/v5.11.0.tar.gz
- sha256sums = 96d137933542cfd133154956969625d40780f9e29ad00904c206170490fac2b5
+ source = python-pymc-5.13.0.tar.gz::https://github.com/pymc-devs/pymc/archive/v5.13.0.tar.gz
+ sha256sums = d13c19af88fba30d8647b9bfd01f271f5a6576f5e496aeb1ea11b5e32431316d
pkgname = python-pymc
diff --git a/PKGBUILD b/PKGBUILD
index c32b6a3dcd25..270b0cc2c27a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Maintainer: Carl Smedstad <carsme@archlinux.org>
# Contributor: xia0er <xia0er@gmail.com>
pkgname=python-pymc
_pkgname=${pkgname#python-}
-pkgver=5.11.0
+pkgver=5.13.0
pkgrel=1
pkgdesc="Markov chain Monte Carlo for Python"
arch=(any)
@@ -15,7 +15,7 @@ depends=(
python-arviz
python-cachetools
python-cloudpickle
- python-fastprogress
+ python-dm-tree # Missing dep to python-arviz
python-graphviz
python-matplotlib
python-networkx
@@ -23,6 +23,7 @@ depends=(
python-pandas
python-pytensor
python-pytest
+ python-rich
python-scipy
python-typing_extensions
python-xarray
@@ -34,7 +35,7 @@ makedepends=(
python-wheel
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('96d137933542cfd133154956969625d40780f9e29ad00904c206170490fac2b5')
+sha256sums=('d13c19af88fba30d8647b9bfd01f271f5a6576f5e496aeb1ea11b5e32431316d')
_archive="$_pkgname-$pkgver"
@@ -47,7 +48,7 @@ build() {
check() {
cd "$_archive"
- local ignore_test_args=(
+ local pytest_args=(
# Requires https://github.com/pyro-ppl/numpyro which is not yet packaged.
--ignore=tests/sampling/test_jax.py
--ignore=tests/sampling/test_mcmc_external.py
@@ -59,35 +60,6 @@ check() {
# Error during test collection.
--ignore=tests/backends/test_mcbackend.py
- # Most time-consuming test files, ignore these to make test duration more
- # reasonable.
- --ignore=tests/backends/test_arviz.py
- --ignore=tests/distributions/test_continuous.py
- --ignore=tests/distributions/test_discrete.py
- --ignore=tests/distributions/test_distribution.py
- --ignore=tests/distributions/test_mixture.py
- --ignore=tests/distributions/test_multivariate.py
- --ignore=tests/distributions/test_timeseries.py
- --ignore=tests/distributions/test_transform.py
- --ignore=tests/distributions/test_truncated.py
- --ignore=tests/gp/test_cov.py
- --ignore=tests/gp/test_gp.py
- --ignore=tests/gp/test_hsgp_approx.py
- --ignore=tests/logprob/test_mixture.py
- --ignore=tests/logprob/test_tensor.py
- --ignore=tests/logprob/test_transforms.py
- --ignore=tests/model/test_core.py
- --ignore=tests/sampling/test_forward.py
- --ignore=tests/sampling/test_mcmc.py
- --ignore=tests/sampling/test_parallel.py
- --ignore=tests/step_methods/hmc/test_nuts.py
- --ignore=tests/step_methods/test_metropolis.py
- --ignore=tests/test_func_utils.py
- --ignore=tests/test_math.py
- --ignore=tests/test_pytensorf.py
- --ignore=tests/variational/test_inference.py
- )
- local deselect_test_args=(
# Fails due to:
# DeprecationWarning: np.find_common_type is deprecated. Please use `np.result_type` or `np.promote_types`.
--deselect=tests/backends/test_arviz.py::TestDataPyMC::test_autodetect_coords_from_model
@@ -107,8 +79,36 @@ check() {
# Fails due to:
# assert array(nan) >= 0
--deselect=tests/distributions/test_multivariate.py::TestMatchesScipy::test_multinomial_zero_probs
+
+ # Most time-consuming test files, ignore these to make test duration more
+ # reasonable.
+ --deselect=tests/backends/test_arviz.py
+ --deselect=tests/distributions/test_continuous.py
+ --deselect=tests/distributions/test_discrete.py
+ --deselect=tests/distributions/test_distribution.py
+ --deselect=tests/distributions/test_mixture.py
+ --deselect=tests/distributions/test_multivariate.py
+ --deselect=tests/distributions/test_timeseries.py
+ --deselect=tests/distributions/test_transform.py
+ --deselect=tests/distributions/test_truncated.py
+ --deselect=tests/gp/test_cov.py
+ --deselect=tests/gp/test_gp.py
+ --deselect=tests/gp/test_hsgp_approx.py
+ --deselect=tests/logprob/test_mixture.py
+ --deselect=tests/logprob/test_tensor.py
+ --deselect=tests/logprob/test_transforms.py
+ --deselect=tests/model/test_core.py
+ --deselect=tests/sampling/test_forward.py
+ --deselect=tests/sampling/test_mcmc.py
+ --deselect=tests/sampling/test_parallel.py
+ --deselect=tests/step_methods/hmc/test_nuts.py
+ --deselect=tests/step_methods/test_metropolis.py
+ --deselect=tests/test_func_utils.py
+ --deselect=tests/test_math.py
+ --deselect=tests/test_pytensorf.py
+ --deselect=tests/variational/test_inference.py
)
- pytest "${ignore_test_args[@]}" "${deselecte_test_args[@]}"
+ pytest "${pytest_args[@]}"
}
package() {