summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2024-03-01 23:00:43 +0800
committerSainnhe Park2024-03-01 23:00:43 +0800
commit699e5689b217e475869fefe3b0da5fe33a8e3b01 (patch)
tree6454b3c29c1dfadd9ef484221d8a1c6d7cac2c20
parent38f516a84fc82dee505b9473c95ee85efaeec0ca (diff)
downloadaur-699e5689b217e475869fefe3b0da5fe33a8e3b01.tar.gz
Update to 1.87.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--patch.json98
3 files changed, 70 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 984bb4961030..6720ac921021 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-features-insiders
pkgdesc = Unblock some features in Code OSS, including features in VSCode Insiders
- pkgver = 1.85.0
+ pkgver = 1.87.0
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features-insiders.install
@@ -17,6 +17,6 @@ pkgbase = code-features-insiders
source = patch.json
md5sums = a270718448070ecda3050b7569510105
md5sums = f11f7ccd925de0398ef2e28b127bb063
- md5sums = cabab602cf1bd7777858c71d207c0537
+ md5sums = a17f01e570df18126948925f694ce4cd
pkgname = code-features-insiders
diff --git a/PKGBUILD b/PKGBUILD
index afa5dadb3ea6..4b8f4979a69d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features-insiders
-pkgver=1.85.0
+pkgver=1.87.0
pkgrel=1
pkgdesc='Unblock some features in Code OSS, including features in VSCode Insiders'
arch=('any')
@@ -16,7 +16,7 @@ source=("${pkgname}.hook"
'patch.json')
md5sums=('a270718448070ecda3050b7569510105'
'f11f7ccd925de0398ef2e28b127bb063'
- 'cabab602cf1bd7777858c71d207c0537')
+ 'a17f01e570df18126948925f694ce4cd')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.json b/patch.json
index 8f2e19707e64..d0d3834ddfda 100644
--- a/patch.json
+++ b/patch.json
@@ -292,7 +292,11 @@
"settingsSearchUrl": "https://bingsettingssearch.trafficmanager.net/api/Search",
"extensionEnabledApiProposals": {
"ms-vscode.vscode-selfhost-test-provider": [
- "testObserver"
+ "testObserver",
+ "testCoverage"
+ ],
+ "ms-vscode.extension-test-runner": [
+ "testCoverage"
],
"VisualStudioExptTeam.vscodeintellicode-completions": [
"inlineCompletionsAdditions"
@@ -327,12 +331,11 @@
"contribEditorContentMenu",
"quickPickSortByLabel",
"portsAttributes",
- "registerIssueDataProvider",
+ "handleIssueUri",
"testObserver",
"quickPickItemTooltip",
"terminalDataWriteEvent",
- "terminalExecuteCommandEvent",
- "saveEditor"
+ "terminalExecuteCommandEvent"
],
"ms-dotnettools.dotnet-interactive-vscode": [
"notebookMessaging"
@@ -421,51 +424,53 @@
"speech"
],
"GitHub.vscode-pull-request-github": [
+ "activeComment",
"contribCommentThreadAdditionalMenu",
"tokenInformation",
+ "codeActionRanges",
+ "commentReactor",
"contribShareMenu",
"fileComments",
"contribCommentPeekContext",
"codiconDecoration",
"diffCommand",
"contribCommentEditorActionsMenu",
- "readonlyMessage",
"treeViewMarkdownMessage",
+ "tabInputTextMerge",
"shareProvider",
"quickDiffProvider"
],
"GitHub.copilot": [
"inlineCompletionsAdditions",
"interactive",
- "interactiveUserActions",
"terminalDataWriteEvent"
],
"GitHub.copilot-nightly": [
"inlineCompletionsAdditions",
"interactive",
- "interactiveUserActions",
"terminalDataWriteEvent"
],
"GitHub.copilot-chat": [
"handleIssueUri",
"interactive",
- "interactiveUserActions",
"terminalDataWriteEvent",
"terminalExecuteCommandEvent",
"terminalSelection",
"terminalQuickFixProvider",
"chatProvider",
- "chatVariables",
- "chatAgents2",
- "chatAgents2Additions",
- "defaultChatAgent",
- "readonlyMessage",
+ "chatParticipant",
+ "chatParticipantAdditions",
+ "defaultChatParticipant",
+ "chatVariableResolver",
"mappedEditsProvider",
"aiRelatedInformation",
"codeActionAI",
"findTextInFiles",
"textSearchProvider",
- "contribSourceControlInputBoxMenu"
+ "contribSourceControlInputBoxMenu",
+ "newSymbolNamesProvider",
+ "findFiles2",
+ "extensionsAny"
],
"GitHub.remotehub": [
"contribRemoteHelp",
@@ -482,6 +487,9 @@
"textSearchProvider",
"timeline"
],
+ "GitHub.copilot-nes": [
+ "inlineEdit"
+ ],
"ms-python.gather": [
"notebookCellExecutionState"
],
@@ -506,7 +514,8 @@
"notebookControllerAffinityHidden",
"contribNotebookStaticPreloads",
"quickPickItemTooltip",
- "notebookExecution"
+ "notebookExecution",
+ "notebookVariableProvider"
],
"dbaeumer.vscode-eslint": [
"notebookCellExecutionState"
@@ -544,8 +553,8 @@
"textSearchProvider"
],
"apidev.azure-api-center": [
- "chatAgents2",
- "chatRequestAccess"
+ "chatParticipant",
+ "languageModels"
]
},
"tasConfig": {
@@ -731,21 +740,46 @@
"default": false
}
},
- "trustedExtensionAuthAccess": [
- "vscode.git",
- "vscode.github",
- "ms-vscode.remote-repositories",
- "github.remotehub",
- "ms-vscode.azure-repos",
- "ms-vscode.remote-server",
- "github.vscode-pull-request-github",
- "github.codespaces",
- "ms-vsliveshare.vsliveshare",
- "github.copilot",
- "github.copilot-chat",
- "ms-azuretools.vscode-azureresourcegroups",
- "ms-edu.vscode-learning"
- ],
+ "trustedExtensionAuthAccess": {
+ "github": [
+ "vscode.git",
+ "vscode.github",
+ "github.remotehub",
+ "ms-vscode.remote-server",
+ "github.vscode-pull-request-github",
+ "github.codespaces",
+ "github.copilot",
+ "github.copilot-chat",
+ "ms-vsliveshare.vsliveshare"
+ ],
+ "github-enterprise": [
+ "vscode.git",
+ "vscode.github",
+ "github.remotehub",
+ "ms-vscode.remote-server",
+ "github.vscode-pull-request-github",
+ "github.codespaces",
+ "github.copilot",
+ "github.copilot-chat",
+ "ms-vsliveshare.vsliveshare"
+ ],
+ "microsoft": [
+ "vscode.git",
+ "ms-vscode.azure-repos",
+ "ms-vscode.remote-server",
+ "ms-vsliveshare.vsliveshare",
+ "ms-azuretools.vscode-azureresourcegroups",
+ "ms-edu.vscode-learning"
+ ],
+ "microsoft-sovereign-cloud": [
+ "vscode.git",
+ "ms-vscode.azure-repos",
+ "ms-vscode.remote-server",
+ "ms-vsliveshare.vsliveshare",
+ "ms-azuretools.vscode-azureresourcegroups",
+ "ms-edu.vscode-learning"
+ ]
+ },
"auth": {
"loginUrl": "https://login.microsoftonline.com/common/oauth2/authorize",
"tokenUrl": "https://login.microsoftonline.com/common/oauth2/token",