summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Repp2020-10-25 11:17:19 +0100
committerSimon Repp2020-10-25 11:35:24 +0100
commit69b30aa5ee91dc8960bc941739906cef9bb4459a (patch)
treeeaf597ccc77d3190465d311d54cba14e6f9889f7
downloadaur-69b30aa5ee91dc8960bc941739906cef9bb4459a.tar.gz
Initialize
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
-rw-r--r--ommpfritt.desktop8
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6575ebb307ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ommpfritt-git
+ pkgdesc = Semantic, procedural, non-destructive vector modelling
+ pkgver = 0.1.3.r568.g62a6fe81
+ pkgrel = 1
+ url = https://github.com/pasbi/ommpfritt
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = lib2geom-git
+ depends = poppler-qt5
+ depends = pybind11
+ depends = python3
+ depends = qt5-base
+ depends = qt5-imageformats
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-translations
+ provides = ommpfritt
+ conflicts = ommpfritt
+ source = ommpfritt.desktop
+ source = ommpfritt::git+https://github.com/pasbi/ommpfritt.git
+ md5sums = 39e4dba5aa7eff71507a96c49457edcc
+ md5sums = SKIP
+
+pkgname = ommpfritt-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d0ebe2e73743
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/ommpfritt/
+/pkg/
+/src/
+/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85d9327871f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Simon Repp <simon@fdpl.io>
+
+arch=('i686' 'x86_64')
+conflicts=('ommpfritt')
+depends=('lib2geom-git' 'poppler-qt5' 'pybind11' 'python3' 'qt5-base' 'qt5-imageformats' 'qt5-svg' 'qt5-tools' 'qt5-translations')
+license=('GPL3')
+makedepends=('cmake' 'git')
+md5sums=(
+ '39e4dba5aa7eff71507a96c49457edcc'
+ 'SKIP'
+)
+pkgdesc="Semantic, procedural, non-destructive vector modelling"
+pkgname=ommpfritt-git
+pkgrel=1
+pkgver=0.1.3.r568.g62a6fe81
+provides=('ommpfritt')
+source=(
+ ommpfritt.desktop
+ "ommpfritt::git+https://github.com/pasbi/ommpfritt.git"
+)
+url="https://github.com/pasbi/ommpfritt"
+
+build() {
+ cd "${srcdir}"/ommpfritt
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DQT_QM_PATH=/usr/share/qt/translations \
+ ..
+ make -j2
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 ommpfritt.desktop "${pkgdir}"/usr/share/applications/ommpfritt.desktop
+
+ cd "${srcdir}"/ommpfritt/build
+ install -Dm755 ommpfritt "${pkgdir}"/usr/bin/ommpfritt
+}
+
+pkgver() {
+ cd ommpfritt
+ git describe --exclude continuous --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
diff --git a/ommpfritt.desktop b/ommpfritt.desktop
new file mode 100644
index 000000000000..f82f6e69967e
--- /dev/null
+++ b/ommpfritt.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Categories=Graphics;2DGraphics;VectorGraphics
+Comment=Semantic, procedural, non-destructive vector modelling
+Exec=ommpfritt %f
+Icon=ommpfritt
+Name=ommpfritt
+Terminal=false
+Type=Application