summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892015-06-29 09:12:55 +0200
committerPhoton892015-06-29 09:12:55 +0200
commit69b4a9d90fab1d0d6f9031b4bb0bdb170ce9b015 (patch)
tree80173f5d8158d8d7d384c7e24edb08bb15ff057a
downloadaur-69b4a9d90fab1d0d6f9031b4bb0bdb170ce9b015.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--libnotify.patch150
3 files changed, 198 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78b1785d044f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = perl-gtk2-notify
+ pkgdesc = Perl interface to libnotify
+ pkgver = 0.05
+ pkgrel = 11
+ url = http://search.cpan.org/perldoc?Gtk2::Notify
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = gtk2-perl
+ depends = libnotify
+ depends = perl-extutils-pkgconfig
+ depends = perl-extutils-depends
+ source = http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Gtk2-Notify-0.05.tar.gz
+ source = libnotify.patch
+ md5sums = 071144ad4a5670b8b2451baf358c4a88
+ md5sums = 39d193a18df5d75ddc79d4c2333c4760
+ sha1sums = b0223dd5a85358c9b92ebc99040201e640612348
+ sha1sums = 55a8c591a4d3c3fb1d23a2c949d52e204f04350f
+
+pkgname = perl-gtk2-notify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66b322a526fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
+# Contributor: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=perl-gtk2-notify
+pkgver=0.05
+pkgrel=11
+pkgdesc="Perl interface to libnotify"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/perldoc?Gtk2::Notify"
+license=('LGPL')
+depends=('gtk2-perl' 'libnotify' 'perl-extutils-pkgconfig'
+'perl-extutils-depends')
+source=(http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Gtk2-Notify-$pkgver.tar.gz libnotify.patch)
+md5sums=('071144ad4a5670b8b2451baf358c4a88' '39d193a18df5d75ddc79d4c2333c4760')
+sha1sums=('b0223dd5a85358c9b92ebc99040201e640612348' '55a8c591a4d3c3fb1d23a2c949d52e204f04350f')
+
+build() {
+ cd "$srcdir"
+ patch -p 0 <libnotify.patch
+ cd "$srcdir/Gtk2-Notify-$pkgver"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make || return 1
+}
+package() {
+ cd "$srcdir/Gtk2-Notify-$pkgver"
+ make DESTDIR=$pkgdir install || return 1
+}
diff --git a/libnotify.patch b/libnotify.patch
new file mode 100644
index 000000000000..49ab8e2cf23e
--- /dev/null
+++ b/libnotify.patch
@@ -0,0 +1,150 @@
+diff -upr Gtk2-Notify-0.05.orig/lib/Gtk2/Notify.pm Gtk2-Notify-0.05/lib/Gtk2/Notify.pm
+--- Gtk2-Notify-0.05.orig/lib/Gtk2/Notify.pm 2008-11-11 23:47:33.000000000 -0700
++++ Gtk2-Notify-0.05/lib/Gtk2/Notify.pm 2013-02-22 06:43:03.000000000 -0700
+@@ -47,7 +47,7 @@ Version 0.04
+
+ use Gtk2::Notify -init, "app_name";
+
+- my $notification = Gtk2::Notify->new($summary, $message, $icon, $attach_widget);
++ my $notification = Gtk2::Notify->new($summary, $message, $icon);
+ $notification->show;
+
+ =head1 INITIALISATION
+diff -upr Gtk2-Notify-0.05.orig/t/notification.t Gtk2-Notify-0.05/t/notification.t
+--- Gtk2-Notify-0.05.orig/t/notification.t 2006-08-27 13:11:57.000000000 -0600
++++ Gtk2-Notify-0.05/t/notification.t 2013-02-22 06:49:35.000000000 -0700
+@@ -2,20 +2,18 @@
+
+ use strict;
+ use warnings;
+-use Gtk2::TestHelper tests => 35;
++use Gtk2::TestHelper tests => 31;
+ use Test::Exception;
+ use Gtk2::Notify -init, $0;
+
+ ginterfaces_ok('Gtk2::Notify');
+
+-my $w = Gtk2::Window->new;
+-my $n = Gtk2::Notify->new('foo', 'bar', '', $w);
++my $n = Gtk2::Notify->new('foo', 'bar', '');
+
+ isa_ok($n, 'Gtk2::Notify');
+
+ my @methods = qw(
+ add_action
+- attach_to_widget
+ clear_actions
+ clear_hints
+ close
+@@ -46,16 +44,6 @@ lives_ok(sub {
+ }, 42);
+ }, 'add_action');
+
+-{
+- my $nw = Gtk2::Window->new;
+- lives_ok(sub {
+- $n->attach_to_widget($nw);
+- }, 'attach_to_widget');
+- lives_ok(sub {
+- $n->attach_to_widget($w);
+- }, 'attach_to_widget');
+-}
+-
+ lives_ok(sub {
+ $n->clear_actions;
+ }, 'clear_actions with existing actions');
+@@ -96,12 +84,6 @@ lives_ok(sub {
+ }, 'set_urgency');
+
+ lives_ok(sub {
+- $n->close;
+-}, 'close before show');
+-
+-$w->show_all;
+-
+-lives_ok(sub {
+ $n->show;
+ }, 'show');
+
+diff -upr Gtk2-Notify-0.05.orig/xs/Notify.xs Gtk2-Notify-0.05/xs/Notify.xs
+--- Gtk2-Notify-0.05.orig/xs/Notify.xs 2007-10-04 06:11:13.000000000 -0600
++++ Gtk2-Notify-0.05/xs/Notify.xs 2013-02-22 06:47:46.000000000 -0700
+@@ -21,8 +21,7 @@ PROTOTYPES: DISABLE
+ my $notification = Gtk2::Notify->new(
+ $summary,
+ $message,
+- $icon,
+- $attach_widget
++ $icon
+ );
+ $notification->show;
+
+@@ -86,26 +85,12 @@ notify_get_server_info (class, OUTLIST c
+ MODULE = Gtk2::Notify PACKAGE = Gtk2::Notify PREFIX = notify_notification_
+
+ NotifyNotification *
+-notify_notification_new (class, summary, body=NULL, icon=NULL, attach=NULL)
++notify_notification_new (class, summary, body=NULL, icon=NULL)
+ const gchar *summary
+ const gchar *body
+ const gchar *icon
+- GtkWidget_ornull *attach
+ C_ARGS:
+- summary, body, icon, attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-NotifyNotification *
+-notify_notification_new_with_status_icon (class, summary, body=NULL, icon=NULL, status_icon=NULL)
+- const gchar *summary
+- const gchar *body
+- const gchar *icon
+- GtkStatusIcon *status_icon
+- C_ARGS:
+- summary, body, icon, status_icon
+-
+-#endif
++ summary, body, icon
+
+ gboolean
+ notify_notification_update (notification, summary, message=NULL, icon=NULL)
+@@ -114,27 +99,6 @@ notify_notification_update (notification
+ const gchar *message
+ const gchar *icon
+
+-void
+-notify_notification_attach_to_widget (notification, attach)
+- NotifyNotification *notification
+- GtkWidget *attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-void
+-notify_notification_attach_to_status_icon (notification, status_icon)
+- NotifyNotification *notification
+- GtkStatusIcon *status_icon
+-
+-#endif
+-
+-void
+-notify_notification_set_geometry_hints (notification, screen, x, y)
+- NotifyNotification *notification
+- GdkScreen *screen
+- gint x
+- gint y
+-
+ NO_OUTPUT gboolean
+ notify_notification_show (notification)
+ NotifyNotification *notification
+@@ -168,6 +132,11 @@ notify_notification_set_icon_from_pixbuf
+ GdkPixbuf *icon
+
+ void
++notify_notification_set_image_from_pixbuf (notification, image)
++ NotifyNotification *notification
++ GdkPixbuf *image
++
++void
+ set_hint (notification, key, value)
+ NotifyNotification *notification
+ const gchar *key