summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-06-15 14:04:13 +0800
committerChocobo12019-06-15 14:04:13 +0800
commit69b85ab7a444e51959cc19c9760fc4aa0927f6eb (patch)
treef0307dd2bae661aef77b6ec05845e8ea1893d1d4
downloadaur-69b85ab7a444e51959cc19c9760fc4aa0927f6eb.tar.gz
newpkg: jansson-git 2.12.r3.gb333f36-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6c6ceb971ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = jansson-git
+ pkgdesc = C library for encoding, decoding and manipulating JSON data
+ pkgver = 2.12.r3.gb333f36
+ pkgrel = 1
+ url = http://www.digip.org/jansson/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glibc
+ provides = jansson
+ conflicts = jansson
+ options = staticlibs
+ source = git+https://github.com/akheron/jansson.git
+ sha256sums = SKIP
+
+pkgname = jansson-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7895ca806b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=jansson-git
+pkgver=2.12.r3.gb333f36
+pkgrel=1
+pkgdesc="C library for encoding, decoding and manipulating JSON data"
+arch=('i686' 'x86_64')
+url="http://www.digip.org/jansson/"
+license=('MIT')
+depends=('glibc')
+makedepends=('git')
+provides=('jansson')
+conflicts=('jansson')
+options=('staticlibs')
+source=("git+https://github.com/akheron/jansson.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "jansson"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "jansson"
+
+ autoreconf -fi
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "jansson"
+
+ make check
+}
+
+package() {
+ cd "jansson"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/jansson"
+}